How to debug search plugin?

I’ve spent almost 2 days tyring to understand how to make search plugin running. All recipes from this forum doesn’t work for me, search not running after all changes made in a system (“Searchable Fields” empty in settings, I can see search service but no results from it etc.). Unfortunately I see no documentation describing how to adjust this plugin so I’d like to try debugging.

I’m using LDAP connection and it works fine itself: users are able to login (right now we’re using Spark), Profile filled with info from LDAP etc. But users are not happy because they cannot search for their colleagues and the option “Just use Jabber ID” isn’t a solution here: it’s inconvinient to remember JID and anyway first of all they have to get such JID from somebody who will be added.

We are using Openfire (with Spark) in our office environment with LDAP (Active Directory) integration.

Our users don’t have to add buddies manually because we have configured that all members of an AD group can see each other (isn’t this the default setting?) and we’ve enabled “group sharing” so that all members of a group automatically can see all members of assigned groups.

With this settings, the search functionality works fine. If I remember correctly (I’m not at work now ^^) it should be possible to search for JID, Name and Email.

I could post screenshots of my settings, but not before Tuesday, so that you can test these settings on your server.

But even without group sharing the search functionality should work correctly.

Is the profile correctly configured? Name = LDAP Name, Email = LDAP Email?


Hi Thomas,

Thanks for your reply. I’m not in the office as well but will check all you said. That will be cool if you could post more info about your config. Right now I just have mo idea what’s wrong: everything looks fine but this thing just doesn’t work.

Hi Ivan,

here are my LDAP settings:

The setting ldap.vcard-mapping looks like this:

<![CDATA[ {sn} {givenName} {mail} {displayName} {displayName} {homePostalAddress} {homeZip} {co} {streetAddress} {l} {st} {postalCode} {co} {Phonenumber} {mobile} {telephoneNumber} {mobile} {facsimileTelephoneNumber} {pager} {title} {department} ]]>

I don’t know if its necessary for the search Plug-In, but we enabled group sharing. This looks like this:

This is the description of this functionality: “You can use the form below to automatically add this group to users’ contact lists. When enabled, this group will only appear in the contact lists of the group’s members.. However, you can share this group with all users or members of other groups.”

Best regards


Hi Speedy,

Thanks for your reply. Unfortunately this all you’re talking about is not my case. I also have needed filters and they works fine. I got your point about group sharing - we’re not using it yet, my problem is that search service doesn’t work at all. One of possible problem here is that I have empty list of searchable fields:



have you tried to delete and install the Plug-In?

You should at least be able to search for JIDs.

Have you tried this:

Start Openfire with Debug enabled

Best regards


Hi Speedy,

Sure I tried to reinstall this plugin. Debug of Openfire gives me nothing - at least I can’t see information specific to given search request. But now I found that I’m in trouble with vCard mappings - if plugin uses vCard mapping and I have no working vCard in the system, that’s absolutely clear that plugin will not work.

Found in documentation that vCard settings must be decorated with [CDATA] tags - I’m using eDirectory and not Active Directory as a LDAP Source, so I’m in doubts regarding correct syntax for vCard mapping. Also in documentation all given examples looks to be used for configuration XML files rather than to be used in Admin Console.

I had setup wrong settings for ldap.searchField property - it must be filled with correct pair of /, like that:

Nickname/cn,Name/sn,Firstname/givenName,FullName/fullname,email/mail,Username/ui d - this string works fine.

I had cn,sn,givenName,fullname,mail,uid which is wrong.