powered by Jive Software

How to disable stream management in openfire 4.3.2

I want to disable stream management in openfire. I have tried adding the following properties

  1. Disabling in openfire.xml does not help
  2. Changing start.openfire.script does not help.
    INSERT INTO OFPROPERTY VALUES(‘stream.management.active’,‘false’,0);
    INSERT INTO OFPROPERTY VALUES(‘stream.management.requestFrequency’,‘0’,0);
    INSERT INTO OFPROPERTY VALUES(‘stream.management.max-unacked’,‘0’,0);
  3. Setting stream.management.active to false (even via admin console) does not seem to help.

openfire responds with enabled request when a stream management enable request is sent.

Please let me know if there is away to disable stream management.

I am also facing the same problem. But I disable the stream management from client side and it works.

XMPPTCPConnection.setUseStreamManagementDefault(false);

In my case I dont have control on the client code, so want to know if we can send a failed response when the clients try to enable stream management.
<failed xmlns=‘urn:xmpp:sm:3’/>