powered by Jive Software

How to increase Java Memory with Openfire Enterprise 3.3.0

Hello, we are running Openfire Enterprise 3.3.0 on a Windows Server 2003, and Java Memory indicates 96% to 98%, with about 160 users, but no more than 50 logged in simultaneously. After reading the threads about how to increase Java Memory, I created a text file and named it openfired.vmoptions.txt, placing it in the C:\Program Files\Wildfire\bin directory on the Windows 2003 Server. The contents of the openfired.vmoptions.txt file are:



I then stopped the Openfire Enterprise server, and restarted it by right-clicking on the light-bulb icon. The amount of Java Memory did not change; I expected to see more than 64MB available.

Can anyone guide me as to what I did wrong, and how to do it correctly?


Hi Dave,

start a “cmd.exe” and rename openfired.vmoptions.txt to openfired.vmoptions.

Take a look at JVM Settings and Debugging - you may also want to add some JVM parameters (IPv4), every one in a new line.


Thanks so much for your quick help. That did the trick. I really

appreciate it.


thanks for your tips! And it is really helpful!

If anyone is searching for this now, the file is called openfire-service.vmoptions and no longer is called openfired.vmoptions. It took me a few minutes to find this.