How to increase Java Memory

Hi All,

How do i set / increase Java Memory on the wildfire server? Is there a way in doing it? Do let me know. Yor help is much appreciated



Message was edited by: f1ea

Hi Jeff,

The configuration varies a bit depending on if you’'re running Wildfire on Windows or *nix. In either case take a look at the Wildfire documentation for details.

Hope that helps,


I have the same issue, running under Ubuntu Dapper, Wildfire v.3.1.0. I added this line to /etc/init.d/wildfired : export JAVA_OPTS="-Xmx300M $JAVA_OPTS"

My box has 512Mb of memory and on the Admin Console, Wildfire reports Java Memory: 32.13 MB of 63.31 MB (50.8%) used

but this will increase until its is >95% and then Wildfire will stop working.

How to I allocate more memory to Wildfire?


Hi everybody

I hope you could understand my bad english…I was looking how to change the VM options to mange the memory in a Windows machine. I have some troubles trying to increase JVM memory. I’'ve already created the wildfired.vmoptions text file in the /bin with the lines



but, when I launch the application again, it seems that nothing has changed, from the admin console, the JVM indicates that i just have allocated just 64M and the server is using about 75% of that amount…I have 50 users and I’'m afraid of having troubles if the server reach the 100%.

Please Help me.

Jose Torres (From El Salvador)

@Jose: see

I have same problem on Slackware Linux. Line in script export JAVA_OPTS="-Xmx512M $JAVA_OPTS" don’'t increase Java Memory for Wildfire.

Is it possible to set Java Memory parameter for changing from Admin Console in next Wildfire versions?

i’‘ve always found it’'s a good idea when specifying the -Xmx flag to also specify the -Xms. if you are expecting the app to need larger amounts of memory, why not allocate up front. try adding -Xms256m to the JAVA_OPTS to ensure those are getting picked up.

and, just for good measure, have you tried the wildfired.vmoptions option?


In centos, I do a command:

  1. which wildfire

  2. /usr/local/bin

Then I use the nano editor:

  1. nano -w /usr/local/bin/wildfire

Look for the line “INSTALL4J_ADD_VM_PARAMS”

INSTALL4J_ADD_VM_PARAMS="-Xms32m -Xmx256m -Xss256k -Xoss256k -XX:PermSize=35m -XX:MaxPermSize=70m -verbose:gc -XX:*PrintGCDetails -XX:*PrintGCTimeStamps -Xloggc:/var/log/wildfire/gc.log"

Hope that help.

Yeaw Sing

So in Ubuntu do you add the Java memory options to /etc/init.d/wildfired file or to a different config file. I’'m looking on my system and am not finding another config file.

Wildfire crashed again today, a neverending loop…

Thanks for the help!!!


if your wildfired script does execute the java call then add it there, but if if calls /usr/local/bin/wildfire you may want to add it there.


Ok, found the file in Ubuntu: /usr/bin/wildfire/bin/wildfire

At the top are the VM_PARAMS options.

I’‘m going to see if this fixes it. Thanks, I’'ll let everyone know how it worked.

It seems to of worked, now instead of Java Memory:

50.95 MB of 63.31 MB (80.5%) used

I’'m showing:

7.04 MB of 296.69 MB (2.4%) used

Here’'s the options I added, do I need others?

vi /usr/bin/wildfire/bin/wildfire

INSTALL4J_ADD_VM_PARAMS="-Xms256m -Xmx300m"

Hope this helps others…!