powered by Jive Software

How to install Spark on Ubuntu 16.04

Hi,

I have a spark server and there are so many user. And they are using spark on windows machine without any problem. Recently a new user has joined and he is using Ubuntu 16.04. It will be great help if you please let me know how to install Spark in Ubuntu 16.04.

Waiting for your response.

Regards,

Tarak Nath.

On the downloads page there is Debian package which you can try. It hasn’t been tested as it was just released and there were no Debian package before. We don’t have much exprience with deb packages. It might have some weird java dependency. Please report any issue you encounter with it. Alternatively you can just use tar.gz. Extract it and run ./Spark command from inside its folder.

I have Ubuntu 16.04 at home and the Debian package worked fine for me, but I downloaded the tar.gz version just in case. If you are using the Unity desktop, then there is a neat little trick you can do to make it easier to start Spark after the first time. When you start it from the command line, lock the icon to the Unity Launcher. That will create a .desktop file in your ~/.local/share/applications folder (you will have to enable viewing hidden files to be able to browse to it in Nautilus). There are probably going to be several .desktop files there. Once you find the right one, you can right-click and set the permissions to allow executing as a program. Then you can copy that .desktop file to your Desktop folder and run it next time that way or from the Launcher (but I think you still have to set the permissions to allow executing as a program, and it might not show the icon on the Launcher properly until you do).

Yes, i have just tried the deb package in my virtual Xubuntu 16.04 and it installed fine. And i was able to run it from /usr/share/spark/bin with ./spark command. It uses OpenJDK 1.8.0_91, which i don’t remember installing. Probably deb pulled it in as a dependency. And it works Tar.gz version already has Java folder included, so you don’t need Java installed on the system.

You probably have OpenJDK from installing the default-jdk perhaps by a dependency from something else like you said. I wish that they would update it to 102 or at least 101, but maybe they will soon. Haven’t messed with Xubuntu in a while as I typically use Unity, but there should be some way to run it without having to drop to the command-line. Maybe create a launcher for it or something in the Panel. Now that I know to use exactly the server name that it registers itself as, I have had no problems so far, even with Spark on Linux.

Yes, i was able to create a launcher on the desktop, which runs the same command. On Ubuntu i lock Spark to the launcher after running it once from a terminal. Just couldn’t make Unity to run in VirtualBox machine lately, so booted up Xubuntu (which has never failed me ).

1 Like

I really like Unity but it is a resource hog and I was irritated when they dropped 2D graphics support for lower-end graphic displays, because in a virtualized environment, you really don’t need all the fancy GUI properties that Unity provides. So far I’ve tried Ubuntu (Unity), Lubuntu, Xubuntu, Ubuntu-MATE, and Ubuntu Studio (just seems like a fancier Xubuntu to me). I had some kind of showstopper problem when I tried Ubuntu Gnome but that was back when it was pretty new and I just gave up on it. Never tried Kubuntu (KDE is beautiful but I’ve never been one for fancy animations and all that, and I have that same utilitarian philosophy in Windows, mainly because I am a developer and not a designer and am not particularly good at the design part self-admittedly). But anyways, I’m guessing that Spark will run fine in any of them?

Spark is Java based, so it should run on anything Provided that Java is accessible and there is some sort of video framework.

I’ve tried MATE with Mint (also Cinnamon). It is nice and lightweight, though it feels to me that Xfce is a bit lighter. Never liked KDE much. Yes, Unity is a hog, but a year or so ago it suddenly became smoother in VirtualBox. Then it started not to load recently. But after the updates today seems to work again.

1 Like

Thank you very much Wroot & Curt Smith !

Also I am sorry for late reply as I was not in my work station.

1 Like