powered by Jive Software

How to Setup S2S Conference Room

Hello,

I was hoping to get some information on how a multi site conference can be accessed. Currently I work for an organization that has 4 Openfire installation at seperate geographic locations. We have configured S2S communcaition and clients can add users from each site to their roster without issue. I have been trying to create a Conference at my site and all local users can connect without issues but users at two other sites cannot connect. The strange thing is that one of our locations can conenct to the conference room and they have the same access as all the other locations. The only difference I can see between this site and the others is that is uses a local database for the user directory while all the other sites use AD.

While troubleshooting I have done the following:

  1. created a dns entry for conference.imserver.dnsname.com

  2. Opened full access in both directions between all the IM servers

  3. Wiresharked both ends of the connection and do not see any errors

  4. Traced firewall logs and do not see any dropped connections

I’m at my wits end and have been banging my head against the wall for the past two days over this issues. Has anybody else been able to get this to work? Is this a problem becasue three of the sites are using AD integration or am I just missing something.

Thanks in advance for your help.

David

Hey David,

The scenario that you are describing should work just fine. I would recommend enabling the debug log in all the server and analyze the handshake when they are trying to establish the s2s connections. Doing a telnet 5269 is another way to verify that basic connectivity is working.

Regards,

– Gato

Thanks for the advice but S2S connections work fine. I am able to communicate with employees at all four locations by adding there JID to my roaster and I can also telnet to port 5269 from our server to all other servers.

So when I try to connect to the remote server using either Pidgin or Spark I enter the conference room name, add the remote IM servers (tried using both conference.servername.com and servername.com) and when I hit join I get “404: Remote Server Not Found”

All servers have the conference.servername.com setup as a public chat.

Cheers,

David

Has anybody been able to get S2S chats working while using AD as the user directory? If so it would be great if somebody can point me in the direction of some documenation on how this should be setup.

The only difference between server configurations is that the site that can connect uses a local users directory and none of the AD sites can connect to any other chat located on any of the remove server… So I’m starting to wonder if it’s an issues with AD integration.

We figured this out…

I’m not sure if this is a requirment but we created DNS records for conference.im-servername.com for all Openfire servers.

What is required is that conference.im-servername.com needs to be added to the allowed white list on the S2S configuration. The strange part is that the whitelist needs to be specified on the Openfire server that is NOT hosting the chat room. Also I tried using *.im-servername.com in the white list and it didn’t work.

1 Like

Hi i had this same problem a while back when i first installed Openfire, i was new and didn’t know much.

If you make a Group chat, conference.yourdomain.com, then all on the same server will be able to access it no trouble.

But if you try to access the conference from a server outside on another network/IP etc… you will get this 404 error.

Easy to solve, just create an A record of conference.yourdomain.com so your IP can be seen on the outside.

J.

I have more than 63 OpenFire Servers connected in differrent networks. DNS records for Openfire domain names as well as records for hosts names are very important if you want to have this working.