How Would I Fix This Openfire Problem?

Here’s the backstory:

I installed Openfire on my Ubuntu 10.10 box and it worked beautifully. As the server was doubling as a testbed, one of the users tried to install Snort on the machine. Failing to do so, he did the following

sudo apt-get remove dec*

in an attempt to remove DECnet from the system.

Nobody used the XMPP services on the machine, but everything was presumed to be okay. After upgrading to Ubuntu 11.04 from 10.10, I checked the Openfire server. It was back to setup. I attempted to set it up and entered into a setup loop that was, for some reason, retaining configuration. I removed the package and tried to reinstall through package manager. I get the following error:

A package dependency could not be found.
More information is available in the detailed report

The detailed report goes on to say the following:

Package openfire is virtual and has no installation candidate

I used the .deb to install it and no luck. I used the .tar.gz file and got nowhere there either. Oddly enough, After using the .deb, I was able to install via package manager (still getting nowhere). Still all a loop.

I noticed that even when “uninstalled” that it seemed to have the service running, so I deleted the /etc/init.d/openfire file and tried reinstalling in all of the above ways. I couldn’t manage to start the service again, nor could I get it to even get back to setup.

Any idea what may have been removed or what I can do to fix this?