powered by Jive Software

Howto access openfire adminpanel via apache

Hi,

how can i make the adminpanel available via https? I don’t want to open port 9090 in my firewall for the world. I also don’t want to configure openfire with lynx Does openfire understand the AJP protocol?

Thanks

Daniel

Hey, meanwhile i’ve opened ports 9090 and 9091…but i still cannot reach the administration panel from outside. Works with lynx though.

Any helpful hints?

I found out, that the jetty listens only on the ipv6 address…is this normal?

Active Internet connections (only servers)

Proto Recv-Q Send-Q Local Address Foreign Address State User Inode PID/Program name

tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 106 12768 1808/mysqld

tcp 0 0 127.0.0.1:80 0.0.0.0:* LISTEN 0 12499 953/apache2

tcp 0 0 U.don’t.need.2know:80 0.0.0.0:* LISTEN 0 12497 953/apache2

tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 0 13543 1327/sshd

tcp 0 0 U.don’t.need.2know:443 0.0.0.0:* LISTEN 0 12501 953/apache2

tcp6 0 0 :::5222 :::* LISTEN 1003 17445 3450/java

tcp6 0 0 :::5223 :::* LISTEN 1003 17446 3450/java

tcp6 0 0 :::5229 :::* LISTEN 1003 14012 3450/java

tcp6 0 0 :::7443 :::* LISTEN 1003 17303 3450/java

tcp6 0 0 :::5269 :::* LISTEN 1003 18452 3450/java

tcp6 0 0 :::22 :::* LISTEN 0 13545 1327/sshd

tcp6 0 0 :::7070 :::* LISTEN 1003 15545 3450/java

tcp6 0 0 :::7777 :::* LISTEN 1003 14011 3450/java

tcp6 0 0 :::9090 :::* LISTEN 1003 14008 3450/java

Come on, anyone? anything?

have you assigned 9090 port allow in iptables

http://www.igniterealtime.org/builds/openfire/docs/latest/documentation/install- guide.html#linux

Secound Link Is GOOD (In this second Link some extra setting are there )


https://library.linode.com/communications/xmpp/openfire/ubuntu-12.04-precise-pan golin

Third one is VIDEO Link


http://sysadmincasts.com/episodes/10-openfire-xmpp-jabber-on-centos

This three links will help you

hi, thanks for the reply…

i’m using ufw and i added a rule for 9090 and 9091

?

Finally found it:

My ISPs firewall blocks 9090. So it was a firewall problem, but not on the server side…

Thanks.