powered by Jive Software

HTTP 404 "security-audit-viewer.jsp"

After upgrade from 4.4.2 to 4.4.3 I face with a 404 error when try to access to Audit Viewer.

Thanks, I have filed OF-1916

Can you confirm the OS and Java version you’re seeing this problem with? Also, does the System Properties page work OK?

Thanks,

Greg

I can reproduce it on RHEL8 / “1.8.0_232 Oracle Corporation – OpenJDK 64-Bit Server VM” . The System’s Properties page does not 404.

Same here with built-in Java - 1.8.0_202 Oracle Corporation – Java HotSpot™ 64-Bit Server VM and with 1.8.0_222 AdoptOpenJDK – OpenJDK 64-Bit Server VM
Windows 7

I don’t think OF-1903 PR 1487 made it to the 4.4 branch!

1 Like

Yup, that’s almost certainly the culprit. Thanks!

Ubuntu 18.04 Server 64bits and JAVA 1.8.0_222 Private Build – OpenJDK 64-Bit Server VM

Openfire 4.4.4 is now released, which should resolve this issue.

1 Like

YES, the 4.4.4 version resolve the issue.