powered by Jive Software

Http-Bind; 404 error

Well… I have been pounding away at this for weeks searching the boards and everything, still no luck getting HTTP-BIND to work. Here’s what I get when I go to myserver.domain.net:8080 (I left the default port, for now).

HTTP ERROR: 404

NOT_FOUND

RequestURI=/

Powered by Jetty://

I’ve see a few posts for this, but no solutions. Does anyone have any ideas what I may be missing?? I’m running Openfire 3.6.0. I did install the latest Red5 pluggin and that seems to be working, but this error… is it keeping me from running iJab and/or jwChat???

Any help is MUCH appreciated. Thanks!!

Hi,

Are you certain http-bind is set to run on port 8080? Also, are you sure http-bind is running? There was a bug in OF 3.6.0 that would prevent http-bind from starting at startup.

aryl

Ah… indeed a good question. I bet that is the problem. Is there a way to start http-bind manually, or a way to test to see if it’s started?

I’m hesitant to upgrade… not sure why, just that I am.

Ah… indeed a good question. I bet that is the problem. Is there a way to
start http-bind manually, or a way to test to see if it’s started?

Just go onto the admin console and submit your http-bind settings page. That
will force an update.

I’m hesitant to upgrade… not sure why, just that I am.

You should from 3.6.0a, there is a major security issue with that release.

Indeed, upgrade I did. Nice!

Unfortunately, I still get that error and iJab and/or jwChat is still not working.

In order to get jwchat to work with openfire I had to make some changes to jsjac and jwchat.

See: http://www.igniterealtime.org/community/message/156357#156357

Well… after a couple of upgrades (Openfire and iJab), I got it all working. I’m not sure that there was anything wrong other than each software was a bit out-dated.

Nonetheless… I have to say, I love Openfire and iJab. What a great combo! Now, all I need to do is figure out how to get this Red5 integrated a bit so my users can enjoy audio/video chat and desktop sharing. Go Go Gadget Goodies!!

Thanks to all who helped!!

I’m using Openfire 3.6.3 (latest as of today) and iJab 0.1.7 (latest). I’ve deployed iJab in apache 2 and followed the instructions on the various post but it’s just saying “service unavailable”

How did you get it to work? Did you need to follow the SASL post - I just disabled SASL (var authType = “nosasl”;) in the iJab.html

Gosh… it’s been so darn long… I don’t really remember.

I think I may have installed the RED5 plugin, and then I copied the iJab into the Red5 directory. Sounds a bit odd, and I am certain there are better ways, but I figured since that used the same port (at least in my case) it would make sense to just install it there. Then, I pointed my broswer to that location.

Sorry I can’t be of more help.

It was sooooo long ago.

Yes, It works in this way, but you have to point to http://ip:7070/red5/ija. Have you figured out how to configure the port-binding, which will allow user to point to normal web address(without specify the port in URL)?

Thanks