powered by Jive Software

Http-Binding is not working anymore after uploading new certificate

I have installed Openfire 4.5.1 on Debian 9. I was upgrading from a earlier version but even Reinstalling the whole System didn’t help. After setting up Openfire everything works fine - sending images in Conversations, … The only problem is the self-signed certificate. I want to use a Letsencrypt Cert. But after uploading the files with help of the Certificate Manager, the Http-Binding function is disabled. It can’t be enabled anymore. Deleting the Signed Letsencrypt certificate and using the self-signed again doesn’t help. Has anyone an idea what to do?
If its a simple error caused by myself i have to say sorry - i am new at this topic.

Have you tried restarting Openfire? My advise is to review the log files (perhaps after increasing the log leven to ‘debug’). It probably holds clues as to what’s going on.

1 Like

I only used the “restart HTTP-server” Button which appears after changing the certs. Restarting Openfire did help. Thanks!