powered by Jive Software

Http-binding, JWChat, VH Apache2

Hi,

I want JWChat to use http-binding on wildfire. I precised I read a lot of threads about that but didn’'t find an answer.

I’'m using wildfire 3.2.3 with LDAP Authentication on a debian sarge machine.

I put jwchat in in the directory /var/www/jwchat and wrote a virtual host in apache2 with jabber.domain.com, so http://jabber.domain.com:8080 goes to the page Wildfire displaying “HTTP Binding Service”, so I think http-binding is working for wildfire.

By the way, is that normal I don’‘t need to write http://jabber.domain.com:8080? Because I saw it’'s necessary to put a rewrite rule in my VH apache like for example:

"ProxyRequests off

ProxyVia off

ProxyPass /http-bind/ http://jabber.example.com:http-bind port/http-bind/

ProxyPassReverse /http-bind/ http://jabber.example.com:http-bind port/http-bind/"

(where should be this directory http-bind? I have nothing in wilfire directory, maybe it’'s virtual?)

In the JWChat config.js, I put (for the most important variables):

var SITENAME = “127.0.0.1”

var DEFAULTRESOURCE = “jwchat”;

name:“Open Relay”,

description:“HTTP Binding backend that allows connecting to any jabber server”,

                    httpbase:"http://127.0.0.1:8080/",

type:“binding”,

default_server: SITENAME

(I precise I tried jabber.domain.com instead of 127.0.0.1, but same problem)

Btw, where can I see the log when I put DEBUG=0 ? I try Debugger.html but a blank page where I can’'t choose the level log.

When I go to jabber.domain.com, I have the Start page for Jwchat where I can log in. If I put my login and password, a new window appears but my ID stay in black and nothing happens…

Where I’'m wrong…?

Thanks for your answers!

Gauthier

I am also trying this out, but I too get the same thing

what exactly is the URL on which wildfire HTTP Binding is listening that I can configure Apache to Rewrite?

You have to tell your JWChat the proxy name, in your case in the config.js

httpbase:"/http-bind/",

type:“binding”,

default_server: SITENAME

“http-bind” is more like an alias, not a real location.

Also, I think your lines

ProxyPass /http-bind/ http://jabber.example.com:http-bind port/http-bind/

ProxyPassReverse /http-bind/ http://jabber.example.com:http-bind port/http-bind/"

should read

ProxyPass /http-bind/ http://jabber.domain.com:8080

ProxyPassReverse /http-bind/ http://jabber.domain.com:8080"

Hope this helps.

I’‘ve attempted to follow these same instructions, and I run into a problem whereby I enter http://sample.server.com/http-bind, and no ProxyPass happens - all I get is an error that says “The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.” I’‘ve been running this server, so I know it’'s not down…any ideas?

Thanks.

Don’'t leave out the finishing slash after http-bind ("/"). Other than that, I never saw that kind of error. Can you connect with a regular jabber client to Openfire?

It could also be that your Webserver is running into a client limit.

Fixed that error - silly thing having to do with Apache and SELinux permissions - yuck.

Now, I’‘m able to log in, but no one shows up on my buddy list…Openfire can see other users, but JWChat can’'t…??

What was the problem with SLES? I’'m having trouble getting JWChat to talk to a Openfire across two SLES servers.