powered by Jive Software

Http error: 404

I need help with a problem; when I try to connect to admin Openfire web page I got the next error message: HTTP ERROR: 404. Any idea?

Thank you

I’ve just downloaded and installed OpenFire and changed the default HTTP and HTTPS ports to 80 and 443 after confirming those weren’t in use (Go, Nmap!). I’ve gone as far as restarting the Openfire service and restarting the server, all for naught.

The install is on Windows 2003 Server R2 Standard edition, 32-bit with all the latest Microsoft patches in place.

This is what I get:

HTTP ERROR: 404

NOT_FOUND

RequestURI=/

Powered by Jetty://

Any guesses?

Hi,

do you run IE locally or from a client? Maybe the IE server settings do cause some problems.

LG

In my case, I’ve tried it both locally and from another system, and get the same results in Firefox or MSIE8.

I have openfire 3.6.3 linux version on ubuntu (also on slackware).

After the initial installation the admin web interface was working corectly, but looks like if do not log out from the web interface and reboot linux then you get the HTTP ERROR: 404 when you try to reconnect to the web interface.

My temporrarly solution is: I installed the add-on to export the users then I saved the users config file, then I removed openfier and reinstalled and last I imported the users config file.

To connect to admin web interface I used IE and Mozila from a second windows PC.

I would like to ask Steve where can I change the port 80 to 443?

I would like to ask Steve where can I change the port 80 to 443?

In the administrator console, click on the server settings tab, then on Http Binding settings on the left side. That’s where I changed it. I wanted standard ports as it’s eventually going to be a public server.

Unther HTTP Binding I have “** Enabled ** - Clients can connect to this server using HTTP binding.” and the default value for the Port is 7070 and for SSL port is 7443. I tried to change SSL from 7443 to 443 (or Port from 7070 to 443) but when I press save I got thr error message: “An error has occured configuring the HTTP binding ports, check the error log for more details.”

With SSL set to 7443 I tried to connect using https://server_IP_address:7443 and after I get the certificate I have the same error message HTTP ERROR: 404

I would like to mention here that even if I log out from the web admin interface after linux reboot I am unable to connect the admin web interface.

After I changed Admin Console port from default port 9091 to 9092 looks like the the web admin interface works well after linux reboot. I believe is because had also the transmission web interface on port 9091.

(fix)

All addresses
9092

Admin Console
The port used for secured Admin Console access.

Thank you all

fix: modify from openfire.xml file and change 9091 to 9092 then restart the service.

Here’s what I’ve found out from Wednesday’s live chat (thanks to guus):

Openfire will provide you with a number of interfaces that can be used by XMPP clients to talk to the server* - *two of them are Bosh interfaces; Although they’re accessible over HTTP, they’re not intended to be used by end-users (but rather by a http-based xmpp client)… I believe [straight http/https connection are not supported], but one of many available plugins might provide that functionality, but I’m not sure.
So, that looks like a no-go to me on a client-less setup, barring finding a plug-in to deal with it.

Hi,

do you really want to bind both the web admin console and the HTTP bind/bosh port to ports 80 and 443?

The defaults are 9090+9091 and 7070+7443. And you may want to keep them unique and above 1024. Otherwise you need to Openfire as root and this is something one should not do.

LG