HTTP ERROR: 500 on Wildfire 2.6.2 upgrade

Hey guys, I was going through a completely routine upgrade from 2.6.1 to 2.6.2 and upon trying to advance to the very first step (I click “English” then “Proceed”) I get the following error:



Powered by Jetty://

I have never had a single problem upgrading before… is there something new I need to know about?

Hi Travis,

there was imho no change, do you see errors in the log files? I did see this error while cookies where not activated long time ago.


Hey guys, I was going through a completely routine


you should describe it better i’'m sure my routine is completely different than yours.

OS? exe, rpm, tar.gz?

I do:


tar -zxvf wildfire_2_6_2.tar.gz

cd wildfire/bin/

./wildfire start

That’'s about it guys, when it comes time to enter the MySQL info I enter the same DB and server I have been using… Wildfire usually “just works.” This time though, I never even made it that far…

I am gonna look into it being a cookie issue like you said, but I need to plan the next time to bring everything down.

Thanks, I’'ll let you guys know how it goes.

Hi Travis,

I wonder if you did change your browser settings. But you may want to backup your wildfire.xml file before the update and then restore it, there the configuration is stored.


It looks more a first install process than upgrade to me. Personally i extract it first and then copy all (except /conf and /logs) to the installation fodler (/opt/wildfire in my case). So, anyway you should backup wildfire.xml, you really dont have to go through a setup every time you upgrade the server.

Ya, I have done that before but honestly… for me, it’'s just easiest to do a “new” install. All my settings are saved in the DB so I could honestly care less if I keep my logs or not. I move the old directories so I can always roll back to an old version with a simple mv command. Something about starting fresh seems like a good idea to me.

Regardless though, I still got the 500 error for some weiiiird reason. I will try and find time tonight maybe to mess with this again.

I had this same problem. Took me a few annoying hours to figure it out but it was a simple error that should only be a warning.

Either Java or the code itself is trying to resolve the interface ip address to a hostname and is failing. In my case, it was a new development server that did not have a hostname yet. Once I added a hostname to /etc/hosts, everything worked fine. /b

I even copied a known good /opt/wildfire install to fix the problem. The server ran fine but debug errors mentioned gethostbyname errors and that led me to the hostname issue.


dufflepods fix worked for me as well. Including a line similar to this works for me localhost.localdomain localhost myhostname

Hey Guus,

Did you have any exception in the logs? I would like to see if there is anything we can do to prevent this problem.


– Gato

I did a quick check (removed all lines from /etc/hosts and restarted the setup). There’'s nothing mentioned in any of the files in wildfire/logs/ or in nohup.out.

I’‘m not sure if you can prevent the error. I think it’‘s a misconfiguration of the base system. If I’'m not mistaken, Apache will throw a similar error if you forget to configure your hostname.

I’‘m not at all sure if it’‘s possible, but perhaps the default HTTP 500 error page of Jetty can be replaced temporarily during setup? It’'s somewhat of an ugly hack, agreed.

Another solution might be to duplicate parts of the (Jetty?) code that produces the error, and have it throw an exception that Wildfire can catch.

For the record: I’'m working with the 3.0.0. release, not 2.6.2 as the title suggests.