powered by Jive Software

I am convinced that LDAP doesn''t work

I set up Wildfire LDAP with my Windows 2003 server. This is the error message I get when I try to log in to the Admin console. I have never been able to get it to work. I don’‘t know much about LDAP. My AD isn’‘t set up extremely complex. I don’'t know if something is blocking my ability to use port 389.

Any help would be greatly appreciated!

-> server.com:389

0000: 30 49 02 01 01 60 44 02 01 03 04 31 63 6E 3D 49 0I…`D…1cn=I

0010: 6E 73 74 61 6E 74 4D 65 73 73 61 67 69 6E 67 2C nstantMessaging,

0020: 63 6E 3D 42 75 69 6C 74 69 6E 2C 64 63 3D 62 65 cn=Builtin,dc=se

0030: 63 6B 77 65 73 74 2C 64 63 3D 63 6F 6D 80 0C 64 rver,dc=com…d

0040: 33 61 64 21 79 2E 76 31 70 33 72 password

<- server.com:389

0000: 30 84 00 00 00 67 02 01 01 61 84 00 00 00 5E 0A 0…g…a…^.

0010: 01 31 04 00 04 57 38 30 30 39 30 33 30 38 3A 20 .1…W80090308:

0020: 4C 64 61 70 45 72 72 3A 20 44 53 49 44 2D 30 43 LdapErr: DSID-0C

0030: 30 39 30 33 33 34 2C 20 63 6F 6D 6D 65 6E 74 3A 090334, comment:

0040: 20 41 63 63 65 70 74 53 65 63 75 72 69 74 79 43 AcceptSecurityC

0050: 6F 6E 74 65 78 74 20 65 72 72 6F 72 2C 20 64 61 ontext error, da

0060: 74 61 20 35 32 65 2C 20 76 65 63 65 00 ta 52e, vece.

akincaid

“I don’'t know much about LDAP.” If you don’‘t know much about what you are doing please don’‘t say "I am convinced that LDAP doesn’'t work" Please fix your subject. It is misleading.I have ldap set up and it work. There are a lot of ldap AD user out there and they all work. Then let us know what wildfire version you are using and how you have configure your wildfire.xml , please post error warn info debug log also.

Regards,

wmhtet

akinaid,

sorry about that abrasive arrogant a-hole who replied. Don’‘t listen to him, or atleast all of what he says. He’‘s whats known as a super geek who got wildfire to work because thats how he get’‘s his jollies. Now for the rest of us who need to get this to work because we gotta, there are many posts where people explain how they got it to work. Just search the forums. oh and if you have your xml file, post it, so we can see what’'s going on.

We’‘ll get through this as a community. A friendly one. Not one that’'s filled with dorks who try to put us normal folk down.

In Solidarity!

Clyde.

hmmm…

name-calling…

peace

Wild Fire 2.5.1 is released today and the subject “I am convinced that LDAP doesn’'t work” is misleading for other people to think that there is a major bug with the release .

Message was edited by: wmhtet

Yeah,

wmhtet is the ]:). He’‘s to silly to scry. I’‘m also convinced that LDAP doesn’‘t work, so why the hell for God’‘s sake do you try it? Please don’'t post any log messages or configuration settings, we all get bemused of too much information.

LoLG

I’'m seeing tons of LDAP related posts here, but that one is funny Jive Community is really very friendly and helpful. Having hanging out here for a year and seen only one or two times of rudeness. Really nice forums.

wmhtet said the right thing. You dont mess around with stuff you dont know. And this thread’‘s topic is really confusing. As i’'m seeing almost everyone has problems with LDAP setup at first. So like wmhtet said, posting all configuration and logs here is what akincaid should do.

clyde, akincaid or whatever else nickname you may have, i see no logic to say you’‘re sorry for some other man’‘s saying. Especially that you’‘re not a moderator or owner of this forum. And how are you going to make this Community good one if your posting is full with insults? Just dont take it too personal. Let’'s make a constructive dialog and solve issues

Thanks a lot for the berating! That really helps me with my LDAP problem. For you Gentleman who actually took the time to post in civility I appreciate your time! For the uber geek - get screwed! Don’‘t reply if you don’'t like the post…anyway, here is my XML file:

  • <![CDATA[

(&

(objectCategory=Person)

(memberOf=cn=users,ou=it stuff,ou=it staff,dc=domain,dc=com)

(!(userAccountControl:1.2.840.113556.1.4.803:=2))

(sAMAccountName=)

)

]]>

Hi,

please put some and statements around your file so it is displayed properly.

LG

Never mind, I got it to work. In the AdminDn field I had to use adminaccount@domain.com, and I had to remove my search filter. Now I need to figure out why my search filter is wrong.

Also, I am trying to use Pandion as my client, and I am having trouble there.

Well, why don’'t you post the search filter and let everybody investigate

I posted a comment that shows how I solved my issue. Really it was a searchable answer in the forums.