powered by Jive Software

I can't add new account when I use spark

hi,

I can connect openfire by spark when I created a new account in the control page,but when I logout and use spark client, need to create a new account,it can’t.

what’s happening?

Which version of Openfire and Spark? Do you have In-band account registration enabled in Admin Console? Usually it is disabled to prevent spam accounts creation.

hey,wroot

openfire and spark version are 4.2.1 and 2.8.3

Does it need to set DNS at the client when I create a new account by spark?

at the create a new account by spark client,does it use the same port 5222?

I can login any user in the client except that can’t create a new user, do I input the wrong domain?

2

3

I can login when I use the same domain

You need to enable inband registration

Also, using IP address as your domain name is a really bad idea. But now you have to rerun Openfire’s setup or start from a scratch to fix that. You should use DNS names for domain in both server and client. It always uses 5222 port.

hey,wroot

I also enabled inband registration, the issue is still happening. could you give me the others advise?

What is the exact error, in English?

“create a new account” shows can’t connect to domain.
in the spark menu, key the same domain, I can sign in OF, search and chat with anyone

note:domain is 192.168.1.24

BTW, just now I have reinstalled OF, still can’t be created a new account by the spark client

I think you will have to use some real domain instead of IP address for this to work. Thougj i haven’t tried account registration on Openfire 4.2.1, but it worked with 4.0.2 a while ago. You can also try 2.7.7 and see if there is any difference https://github.com/igniterealtime/Spark/releases/tag/v2.7.7

well, I will have a try, thanks for wroot.

wait for my good results

hi, wroot

yeah,spark version 2.7.7 can create new account by use ip address, thanks your support!