powered by Jive Software

I can't authorize anyone

I have recently set up openfire chat server on my server and when I add users to my Apple iChat I can’t authorize them. I thought it might be a problem with iChat so I installed spark and have the same problem. I think all of my settings are correct. Can anyone help me?

We need more information, now it’s hard to start to investigate. Step by step preferable. So, you have installed Openfire and launched Admin Console, created users in there and now you have connected to your server using one of the created users login/pass with iChat. Then you are trying to add some of users you have created. How are you adding them? someuser@servername this is correct format in case your server’s name is resolvable in your network/internet. Or uou can set up DNS, edit hosts files or just use someuser@servers-IP-address.

Maybe Subscription plugin can be useful.

http://www.igniterealtime.org/projects/openfire/plugins/subscription/readme.html

You can install this plugin via Admin Console.

After I set up the admin console I addded a admin user and then a secon user using the user@fields-associates.org. Then I logged into ichat jabber with the second user and tried to add the first user to my buddy list and it says auth pending. I log into the admin user in ichat and I can find no way to authorize the user to my buddy list. We use jabber at my business and we have no trouble there but it is built into OSX 10.4 server. I also tried using the spark chat software with the same result. I’m trying to offer this service to my clients that I host web sites for and it is getting a little frustrating.

The subscription didn’t work. I opened it up to all and got the same thing.

So i think this could be a’la DNS issue or maybe firewall/router etc. But maybe you would have to wait for a help of someone with more experience in such questions. I only have Openfire in local network so it’s fairly simple. As i understand your server should be reachable from the internet. So, you have set the name of your server as fields-associates.org? Is this name resolvable from the internet? Well, i dont know much about DNS, but there should be some configuration involved. And is there firewall or like? You should let through or forward 5222 port to the server. This wount be the case if you are trying to login and add users on the same machine, but you can face that problem in future.

Pending in this case i think means not that you’re unable to authorize, but that client just cant understand/find user or server you are trying to add. What’s the name of the machine you have installed Openfire on? maybe you should try adding contacts like someuser@machine_name. Again this could work if you’re trying locally. I think Openfire setup suggests machine’s name as server name in setup process. Maybe i’m wrong. Havent done clean install for a long time.

P.S. some time ago there was a KB article at jivesoftware.org about contact’s adding, JIDs etc. Could be helpful for newbies if someone would write such Document here.

Hey Scott,

A common reason for this problem is that users are adding an invalid address for the contact to add. So if the xmpp domain of your server is example.com then user accounts will have addresses of the format john@example.com. That means that when you add someone to your roster you have to specify as mary@example.com and not just mary. In the main page of the admin console you can see what’s your xmpp domain that you are using. Make sure that example.com, in my example, is replaced with the value that you are using in your setup.

Regards,

– Gato

I did have a discepency in that but changed it. I still have the same issue. However, if I turn on the filters they will work but no chats get thru and the user always says pending or waiting auth. This is getting VERY frustrating.

Previous presence subscriptions will still be broken. New subscriptions using the correct JID (username@domain) will work. If you are still seeing this problem open the XML window/console and post here the XML when adding a contact to your roster.

Regards,

– Gato