powered by Jive Software

I can't view other participant in JitMeet

Hello everyone,

I would like to say that, this is a amazing project and I think i’m gonna need this near future.

As a newbie I would like try to install jitmeet on my local testing server.

And I think all goes well until I stuck on this problem.

I really hope anyone can help me to find a clue for this problem.

FYI :

openfire 3.9.3 installed on ubuntu 12.04 server

I’m using jitsi videobridge 1.3.0

ufw status inactive

and when I type http://172.16.3.138:7070/jitsi/apps/jitmeet, jitsi create a new conf room, but when other person join, I can’t see their face, it’s only a gray shadow on right bottom chrome browser.

anyone can give me a clue ? or maybe already solved this kind of problem ?

NB : some screenshot for more information

Best Regards,

Indra Ivan





I had the same problem even with DMZ and all ports opened. It has to do with NAT. I fixed it pretty easily by using a VPN that punch hole through. See post below

Hello Jay,

I’m not sure I understand about problem with NAT, cause I don’t use NAT in my internal research network

But, I discover this error on chrome console, and still I don’t know how to solve it

Can you help give me some clue about this ?

POST http://172.16.3.138:7070/http-bind/ net::ERR_CONNECTION_REFUSED strophe.jingle.bundle.js?v=8:3k strophe.jingle.bundle.js?v=8:3Strophe.Bosh._processRequest strophe.jingle.bundle.js?v=8:3Strophe.Bosh._onIdle strophe.jingle.bundle.js?v=8:3f.Connection._onIdle strophe.jingle.bundle.js?v=8:2

Strophe: request id 11.1 error 0 happened strophe.jingle.bundle.js?v=8:15Strophe.log strophe.jingle.bundle.js?v=8:15f.error strophe.jingle.bundle.js?v=8:2Strophe.Bosh._onRequestStateChange strophe.jingle.bundle.js?v=8:3

Strophe: request errored, status: 0, number of errors: 1 strophe.jingle.bundle.js?v=8:11

POST http://172.16.3.138:7070/http-bind/ net::ERR_CONNECTION_REFUSED strophe.jingle.bundle.js?v=8:3k strophe.jingle.bundle.js?v=8:3Strophe.Bosh._processRequest strophe.jingle.bundle.js?v=8:3Strophe.Bosh._throttledRequestHandler strophe.jingle.bundle.js?v=8:3Strophe.Bosh._onRequestStateChange strophe.jingle.bundle.js?v=8:3

Strophe: request id 12.2 error 0 happened strophe.jingle.bundle.js?v=8:15Strophe.log strophe.jingle.bundle.js?v=8:15f.error strophe.jingle.bundle.js?v=8:2Strophe.Bosh._onRequestStateChange strophe.jingle.bundle.js?v=8:3

Strophe: request errored, status: 0, number of errors: 2 strophe.jingle.bundle.js?v=8:11

POST http://172.16.3.138:7070/http-bind/ net::ERR_CONNECTION_REFUSED strophe.jingle.bundle.js?v=8:3

Strophe: request id 13.3 error 0 happened strophe.jingle.bundle.js?v=8:15

Strophe: request errored, status: 0, number of errors: 3 strophe.jingle.bundle.js?v=8:11

hover in blob:http%3A//172.16.3.138%3A7070/fa79dcc1-dd32-4b56-9020-434e4b5d1b56 app.js?v=26:706

POST http://172.16.3.138:7070/http-bind/ net::ERR_CONNECTION_REFUSED strophe.jingle.bundle.js?v=8:3

Strophe: request id 14.4 error 0 happened strophe.jingle.bundle.js?v=8:15

Strophe: request errored, status: 0, number of errors: 4

There are many posts here about using a host name and not an IP address

Hello Dele,

So you say, I must use hostname instead of IP address ?

Thank You

I can tell you from personal experience about how important hostname is when initially setting openfire up!

  1. First setup mistake was allowing the pc name to be hostname.

  2. Second try was setting IP as hostname

  3. Then just picked host.local and was fine. 3rd try!

Now I can get to it by host or IP

But I assume you have http bind and bosh settings correct too?

Hello Jay,

To be honest I don’t know where to setup http-bind and bosh, I already search in this forum about what happening to me right now and they show config.js for jitmeet, when i’m compare their with mine (/var/lib/openfire/plugins/apps/jitsivideobridge/jitmeet), the content is whole different.

I also assume that, my problem need http-bind and/or bosh setup (looking from err console chrome), but i cant find setup files for both of them.

Can you tell me where i can find setup files for http-bind and/or bosh ?

So your running a linux box right? I don’t know anything about how openfire runs with Linux, I’m running Server 2008.

But if you have the web interface like I do it’s under server settings > http bindings. Mines on and Bosh enabled.

1 Like

If you mean under server setting, both of them is already on.

I would like to try again from fresh server without installing other component, and of course try with hostname not with ip address

Wish me luck this one.

Definitely good luck to you! I know I had the same issues you are seeing when I had my hostname set as IP.

The only other thing I could say is that I have the Ethersoft VPN software setup on my box. I had good video on local network but the same black screen issues over WAN until I set that up.

Best luck,

Jay

Hello Jay,

I don’t know where the problem lies, but after fresh installed server and using hostname for openfire server, the video works over my LAN (not yet try on WAN), but I do think for openfire fully worked, it need hostname not ip addess or pc-name. For now i’m satiesfied with this result. Thank you for all of your reply of all my questions.

1 Like

Hey, that’s good news. Feel free to ask questions … I did!