I have a difficulty in file transfer on Android

The server is setup with Openfire. And I have 2 android devices (as A & B for convenience ) running the same application.

They could transfer files without any problem when they connect to the server on my own PC, but could not transfer file properly when connect to a remote server. I don’t know what’s wrong.

For test, I tried to send a file from A to a Spark client, and send a file from a Spark client to A, they all succeeded. It seems the code is correct.

I really don’t know what to do…

Could any one help me?

By the way, the prompt message is “features-not-implemented”

OK, I got it.

Now it works well after I added the follow config:

pm.addIQProvider(“open”,“http://jabber.org/protocol/ibb”, new OpenIQProvider());

pm.addIQProvider(“data”,“http://jabber.org/protocol/ibb”, new DataPacketProvider());

pm.addIQProvider(“close”,“http://jabber.org/protocol/ibb”, new CloseIQProvider());

pm.addExtensionProvider(“data”,“http://jabber.org/protocol/ibb”, new DataPacketProvider());

Hi Eric,

May I ask what version/modification of Smack are you using for Android? aSmack or are you mofidying Smack yourself? I have read over the last week or so several posts that say Smack right off the bat doesn’t work in Android JVM so you have to modify it.

I’ve modded my openfire server to recieve what I want it to, now it’s time to play with the clients, and probably the best place to start is playing with Smack on a PC. However I am curious in any case and want to start off in the right direction.

Any info would be appreciated.


I too am having the issue with Androdi missing several java.beans support. I am getting an error related to missing java.beans.propertydescriptor for one. Android only supports parts of java.beans. I found this post relating to it:

http://stackoverflow.com/questions/5488236/is-there-a-work-around-for-the-androi d-error-unable-to-resolve-virtual-method-j

I also found this: http://davanum.wordpress.com/2008/12/29/updated-xmpp-client-for-android/

but it is several years old now.