ICQ Transport not sending authorization requests, Unbable to add ICQ contacts

Im using OpenFire 3.5.1 with Spark 2.5.8 and the latest IM Gateway Plugin 1.2.3

The accual transport is working fine, and can connect to the ICQ servers fine. I am able to chat with existing contacts that i had associated with my ICQ number that is registered at the gateway, and they show up fine on my budylist in Spark.

This is the problem: When i try to add a new ICQ buddy via Spark, the person on the other end never recieves an authorization request. Its like nothing ever happend.

When they try to add me, i never recieve any sort of authorization request, and they never so much as show up on my budylist.

I tried installing the

Subscription 1.2.0 plugin set to accept all subscription requests and this does not seem to have helped.

Basicly: Why cant i add ICQ contacts in Spark going through an OpenFire server using the gateway plugin?

any help or suggestions on where i could look for log files or information to get to the bottom of this would be apreciated.

bump for great justice

Join the crowd… I also have the same issues with Yahoo … Never receive the requests…

well that sucks… glad im not the only one. I take it its a known issue thats in the bug database?

i tried looking for existing info on this problem but i came up empty handed

dont even know how to begin troubleshooting

for now i installed the accual ICQ client on a spare computer and setup all my employee’s contact lists through that, then register it w/ the Openfire gateway

Howdy! I’ve never been able to reproduce the auth requests not being sent when you add an ICQ contact. There is definitely an improvement point that I need to perform at some point where, when someone authorizes you, we automatically accept the authorization, but that doesn’t sound like the same issue you are running into.

As for Yahoo, unfortunately the OpenYMSG peeps have gone a tad silent lately. However again, I’ve added people and had the auth request go on through, so I’m confused as to why that would be occurring for you.

Do either of you have debug logs turned on and data from when you tried to add that I could look at?

I just sent you something… Hope it helps …

I also have a group and user who never show up in my Spark client, but show up just fine in my Yahoo messenger client…

You sent me info about MSN. =) All of these are mostly unrelated, though they may seem similar.

Can you provide details on the Yahoo group? And ideally debug logs while you are logging into Yahoo? (they’ll show me if the group really exists, in some cases things are stored on client side)


I had this issues with MSN, YAHOO about a year ago (dont know the version before) and I think I solved it by deleting most parts of the database. Don’t know what actually worked, as I tried a lot.

Now I have it again with MSN, YAHOO.

Requests don’t get lost, it’s just that I cannot confirm them with Spark (havent tried other clients now, but if I remember correctly it was the same with Miranda). Spark seems to send out the request for auth, it just does not accept any reply or request from the other side. If you login to webmessenger they are waiting and, once approved there, are showing in Spark when you log back in.

I can’t delete the DB again as I have about 30 people on the server now that surely will be pissed and, as the problem shows up again, this is no real solution (I can’t remember doing something that caused it). My users are managed by AD-connection, btw.

I set up a new server for testing but kept a copy of the database and still have that issue. It does not seem to be related to any Version as I ignored it for some months, hoping that 3.5 would solve it

I will provide you with any log you like (I think its a GW issue, not Spark), just name it…and I’m willing to do extensive debugging if you tell me what you need.

This bug is driving me nuts… :confused:

ummm…might make sense to put that into a new thread? :stuck_out_tongue:


Sorry I just found the thread/issue related to at least MSN: GATE-370

Is there any hope for a quick fix? It’s open for 9 months now with a “not too hard to fix” and I think its a really serious problem…


Deleted ICQ. Tested again and its working…so I might have messed something up or at least, I cannot reproduce the error… I deleted it above.