powered by Jive Software

iJab Configuring with Openfire

I’m going to install ijab as my default im web client. and i need to clarify following lines. please help. Please get my domain as thedomain.com

  1. avatar_url:“http://samespace.anzsoft.com/portal_memberdata/portraits/{username}”,

(where is the avatar folder on openfire?)

  1. domain:“thedomain.com”,

  2. http_bind:“http://samespace.anzsoft.com:5280/http-bind/”,

(What is http bind. is it ok with openfire? i saw follownig lines on admin panel

All addresses
7070

HTTP Binding
The port used for unsecured HTTP client connections.
All addresses
7443

HTTP Binding
The port used for secured HTTP client connections.

then what do i use 7070 or 7443?)

  1. port:5222,

  2. server_type:“ejabberd”,

(what is server type xmpp or openfire or ejabberd?)

  1. muc_servernode:“conference.anzsoft.com”,

(what is this. what do i use?)

  1. vcard_search_servernode:“vjud.anzsoft.com”,

(whaat is vcard server node on openfire)

  1. gateways:[{
    icon:“http://example.com/msn.png”,
    name:“MSN Transport”,
    description:"",
    servernode:“msn-transport.anzsoft.com
    }]

(what is gateway?)

Hi AmilaDG,

first of all,you could visit the iJab site to get all stuff answered, but you need to read some stuff ! Anyway, here are the answers:

1.) This must be a skript on your server, which return the avatar, it will not be stored in openfire

2.) correct

3.) yes it will work both, but you need to configure as well an apache server

you need to change the parameter in the rewriterule to:

RewriteEngine On
RewriteBase /
RewriteRule http-bind/ http://myip:7070/http-bind/ [P]

PT=‘passthrough|PT’ (pass through to next handler)
but you need
P=‘proxy|P’ (force proxy)

But you need to enable the following modules as well:

‘apache’

proxy_module
proxy_http_module

If you want to use ssl you need to set SSLProxyEngine On

4.) correct

5.) server_type:openfire

It would be good for you to read first some pages, if you might not know what MUC is and what it stand for…

6.) MultiUserChat, and this need to be set to: muc_servernode:“conference.thedomain.com

7.) vCard should be the search presence on the server and it should be in your case vcard_search_servernode:“search.thedomain.com”,

But it looks like, that this feature did not work with the BOSH client. So there are still some issues. The search feature works fine with an external client like PSI.

8.) gateways:[{
icon:“http://example.com/msn.png”,
name:“MSN Transport”,
description:"",
servernode:“msn.thedomain.com
}]

The servernode should be configured to the stuff you’ve entered in the gateway sections of your openfire installation for each gateway.

Gateways are transports to different networks,so you can use KRAKEN to get all gateways for the most external networks,like AIM, ICQ, IRC, MSN, Facebook,…

Cheers

MiMose aka Gulli Baer