powered by Jive Software

IM Gateway 1.1.0 Beta: IRC doesn''t seem to work?

I had irc on an older version (1.0.2) and while it worked, it annoyed me since everytime someone talked in an irc channel it broke it up into another chat window. I was excited when I saw groupchat for IRC in 1.1.0.

I installed it, and re-registered my irc creditenials. Immediately I didn’‘t see a window popup like before with the irc MOTD. I whois’'d my jabber client with another irc client, and I showed it. I msged myself, and it popped up a new window. I then msged the ‘‘IRC transport’’ to ‘‘join (channelname)’’. This forced the jabber irc client to join, but never saw anything on my client side that it did, or never say any communication from the channel.

I am using Pidgin 2.0.1 and latest Openfire with beta 1.1.0 of IM Gateway.

Any ideas? Thanks!

Ok, well first of all, a lot of things have changed on that front. I killed the console window and am trying to get it to be a smooth behavior instead of a verbose “bothersome” behavior. =) As a result, I silenced all of the yammerings from the IRC server. In theory I should be able to duplicate all of the needed functionality via XMPP mechanisms so the end user doesn’‘t have to know a lick of IRC. As for joining a chat room, you shouldn’'t do it via IRC commands, you should do it via XMPP mechanisms. You should see a conference.irc.myserver.org component available if you do a disco discovery. Basically, if you wanted to join a chatroom called, say, #ninjas, you would do a muc/groupchat connection to #ninjas@conference.irc.myserver.org/mynickname (of course the nickname is effectively ignored… eventually it will actually balk and tell you you have to use your registered nickname and/or ''help you choose the correct one"). Pidgin should work fine with it. (I actually use Adium X myself, same base of libpurple)

Sweet I joined the channel, but the problem now, communication is one-way. I joined the irc channel, can type fine, but can’'t see any input from the server. Private messages are the exact same way.

Any ideas?

Thanks again!

Eww, that almost sounds like the join didn’‘t “really” work … actually if private messages aren’‘t working, more like the connection didn’‘t work. Hrm. Do you have debug logging enabled? You should be able to see the communication from the IRC server there. Might shed some light on what’'s going on!

Sweet, How do I enable debugging?

It’‘s weird because older gaim (2.0.0betasomething) at home worked to join an irc channel, but the latest pidgin nor PSI are. When I msg my jabber irc client from another irc client, I don’‘t see the messages, but if I use nick@irc.hadm.net as a buddy and msg him from jabber I see it on my other client, but still can’'t reply.

Just to make absolute sure, you are registered on the IRC network aren’‘t you? (irc.freenode.net for example won’‘t let you talk to other people if you aren’'t registered with nickserv)

Debugging can be enabled from the openfire admin console under logs. (click on the debug tab and choose enable and embrace the waves on waves of logs ;D )