powered by Jive Software

IM Gateway 1.1.0 Beta

Hi folk! Attached is the IM Gateway plugin version 1.1.0 Beta. I’‘ll get it put up on the beta plugins page whenever I can, but I’'m not having luck catching up with the Jive folk. =) To install this, just copy it into your openfire plugins directory and let the server auto-extract it. … In theory. Let me cut a moment here and explain what I mean by that.

For some reason there’'s been a lot of instances of the auto-update causing problems. This -appears- to have something to do with the plugin not having time to shut down entirely before the new one is extracted. If you experience problems with none of the transports being available or something like that after the upgrade, remove gateway.jar entirely. Wait for the gateway directory to be removed automatically. Then copy the new gateway.jar into place again.

Anyway, this biggest change with 1.1.0 is MUC/Groupchat support (for IRC only at the moment). I’‘ve also migrated to openymsg so Yahoo support is back on track to hopefully head to stable soon. There’‘s a slew of other improvements, but they are outlined in the change log. I’‘m putting out this beta first for a couple of reasons. I want to hear what issues folk run into with the MUC support and with the Yahoo support. I can’‘t duplicate a lot of problems people have run into with Yahoo so my only way of tracking down if things are fixed is to have y’'all try it. =) So please give it a shot and let me know what you run into!

BTW, the transports that are currently labeled as stable haven’'t undergone many changes. Mostly bug fixes.
gateway.jar (729094 Bytes)

Thanks for that - sounds like a lot of improvements. I’'ll stick it on our dev environment.

I’‘m not sure what’'s happening at Jive though - no posts from Matt or anyone for over a week and no replies to emails from sales either

DeeJay,

Sorry I’'ve been away from the forums lately – things are super busy here at Jive. Gato has also been very very busy doing engineering on Openfire clustering.

I’‘m not sure why you’'d be having any problems getting emails back from sales though. If that continues to be a problem, please feel free to drop me a direct email.

Regards,

Matt

Matt - it was basically for a quote for Openfire for my environment. I CC’'d you on the mail - maybe it got lost/Spam filtered? Also, thanks for Spark 2.5.3 beta 2 - the fix for SRV and SSO should really help in our environment

The upgrade proved pretty disasterous for me; when installed it didn’'t allow connections at all.

The logs indicate the transports started ok, but I couldn’'t interact with them from the client.

After much messing around (uninstalling old versions, restarting etc etc) nothing seemed to fix it, so I’'m now back to the old version

The logs always indicate the transports are ok, even if the unload and reload works. =( I forgot another step to it, Remove the gateway.jar, wait for it to vanish entirely, and then make sure there are no connections to the JIDs the transports use in your server sessions admin pane. It’‘s such a pain that this keeps occuring but you can almost always bet that if you can’'t interact with the transports that something went amiss in that arena. Sigh.

Seems im having a problem registering with the transport. I had an icq, y!, msn, and aim account registered before installing the beta. after upgrading, only the msn would login. I manually deleted them in the admin console but spark does not recognize that they have been deleted. Instead of having the option to enter my info, all i have is sign in and delete registration. Clicking delete information does not seem to do anything.

This error also appears in the error log:

2007.06.01 09:23:45 org.jivesoftware.openfire.gateway.BaseTransport.handleIQRegister(BaseTransport.j ava:606) Error cleaning up contact list of:

Hi snow man, take a look at what I told Deejay. I’‘m betting the upgrade didn’'t handle itself well. (sigh… I wish I could reproduce this easily) Most likely the transport is stuck in some way. AIM and MSN have barely changed at all since 1.0.2.

well actually i read that before i installed it :). i forced all clients to disconnect, deleted the jar, waited til it was gone, and then copied the new jar file there. The gatewayregistration table only shows my msn record. What other tables do i need to check for this old information?

Oh yeah, i also tried deleting the local spark profile so there was no old data there.

Message was edited by: snowman386

Hrm, it sounds like it successfully deleted the other registrations then. Is there more information around that error you posted that might be helpful?

well i restarted the server and i started getting this repeated now. dont know it it helps.

2007.06.01 10:08:45 org.jivesoftware.openfire.ldap.LdapGroupProvider.populateGroups(LdapGroupProvide r.java:679)

java.lang.NullPointerException

at org.jivesoftware.openfire.ldap.LdapGroupProvider.populateGroups(LdapGroupProvid er.java:670)

at org.jivesoftware.openfire.ldap.LdapGroupProvider.getGroup(LdapGroupProvider.jav a:99)

at org.jivesoftware.openfire.group.GroupManager.getGroup(GroupManager.java:184)

at org.jivesoftware.openfire.group.GroupCollection$UserIterator.getNextElement(Gro upCollection.java:102)

at org.jivesoftware.openfire.group.GroupCollection$UserIterator.hasNext(GroupColle ction.java:65)

at org.jivesoftware.openfire.roster.RosterManager.hasMutualVisibility(RosterManage r.java:862)

at org.jivesoftware.openfire.roster.Roster.

Message was edited by: snowman386

Eww… I hate to say it but it helps in a “looks like it’'s something weird going on in openfire itself” way. =/ Might want to ping the openfire support forum with that message. It almost sounds like the LDAP stuff isn’‘t working right. All that’‘s happened from the gateway’'s point of view at that point is it just sent a presence probe to a registered user. Looks like something went stupid in the LdapGroupProvider as it was doing it. (… why the hell is the LdapGroupProvider even involved in handling a presence probe?)

Ok. ive had that ldap group null pointer error forever but everything worked fine including ldap groups :D. I only got the rest of that error after installing gateway 1.1.0. I’'ll ask the nice people on the openfire forum to help me with that error.

daniel,

i totally wiped the database in our test environment and installed 1.1.0 gateway. I removed the local profile as well. It still has the same problem where it looks like im already registered in spark. I still get the LDAP error but i think a brand new database would have fixed it.

I’‘m not really sure what to tell you. I don’‘t know what Spark is doing to determine what transports are available or whether you are registered exactly. It sounds like the LDAP error doesn’'t have anything to do with it though.

well daniel,

i do have good news. having the yahoo transport enabled has not caused the CPU to spike to 100% yet

lol well yes, that is good news =)

I fixed my ldap error but it still does not work. went back to 1.0.2 and all is well.

Tried again - no joy.

I get this logged:

2007.06.01 23:04:53 [org.jivesoftware.util.log.util.CommonsLogFactory$1.error(CommonsLogFactory.jav a:87)

] Line=19 The content of element type “dwr” must match “(init?,allow?,signatures?)”.

Interesting. I can’‘t think of why it would be misbehaving unfortunately. Not sure what to do. Doesn’‘t sound like there’'s any more information to provide =/