powered by Jive Software

IM Gateway inside Intranet

Hi to all, been trying to make the IM gateway work within our internal jabber server, but until today haven’'t been able to do this successfully. MSN and yahoo is just registered but the console said that it was never logge-on to the IM servers. Wondering if we can use an intranet server for the gateway or do we need to use a server with a direct Internet connection.

thanks in advance.

Of course, this internal jabber server should have a connection to Internet. Maybe there is some firewall between them?

Ya know, there’‘s probably no reason why I can’'t offer a simple “can I connect to the proper hostname and port required by this service” check from the admin console… hrm. =)

GATE-86

thanks for the replies. Actually, the internal server has Internet connectivity, but it is through a proxy and not a direct connection. Our proxy server is an ISA 2004 machine. I can actually login to MSN and yahoo on the Jabber server using Windows Live Messenger and Yahoo Messenger. However, when I use my PC and Spark to logon to the Jabber server and register to the IM’'s, I cannot see my IM contact and the Jabber admin console says the the account was registered but was never logged on.

Have anyone solved this problem?

? As far as I know it was solved. What’'s the problem exactly at this point? Does “test connection” work from the admin interface for the service you might be having problems with?

Test connection is ok.

My server is inside intranet with proxy required.

I run Openfire on FreeBSD pc with trasparent proxy. So all trafic for ICQ (port 5190) is proxyied.

But at admin console I see that there were no logins. And ICQ trasport goes offline after about 5 minutes.

Does the transparent proxy connect port 5190 to a specific server, or “any server”?

It connects to any server.

I have no problems with ICQ client using this proxy. But gateway doesnt connect.

I’'ve got IM gateway version 1.0.2

Are you sure your other clients aren’‘t using the other “standard icq port”, not 5190? … unfortunately I don’‘t recall what it is off the top of my head but it’‘s also in the 5000 range. Of course if you know your proxy handles port 5190 it shouldn’‘t be an issue. I’‘m not really sure what to tell you as I’'m no wiz at debugging firewall/nat/proxy setups.

Fortunetly I make setup at this network and I now exact ports.

But I have no access to upper proxy. So no way to organize direct access.

Strange that in openfire admin I have last connection - none. Looks like it doesnt recieve client connection.

Where are you seeing last connect none? The “users list” in the admin console? (in other words, it’'s as if the XMPP account itself never connected?)

I see it in Gateways->Registrations. Last registration - never.

UP

Has anyone same problems?? Whats the disicion?

Have you tried 1.1.0 Beta 6? I fixed one thing in the JML library that may be causing some issues. I just don’‘t know if it’'s going to help with this yet.