powered by Jive Software

Implementing SSL

I require some assistance with setting up SSL on the JM. I have followed the instructions for implementing the SSL and I totally blew up the JM and required a reinstall. I am currently using Exodus 9.1.0 and selected the option “All connections must be encrypted”, but the connection is not encrypted, the msg’'s are transmitted in plain text on port 5222, I have confirmed that the port 5223 is open and listening on the server.

However, when I select the host and port under the connection tab and select “all connections must be encrypted” under the Encryption tab and sniff the traffic from my machine there is no negotiation between my client and the server. The client will send out some info, but nothing comes back.

Is there anything that I’'m missing (obviously I am). Any assistance would be greatly appreciated.

Thank you,

For Exodus I use these Account settings:

Connection Tab:

Enter host name and port=5223

Encrption Tab:

check the “Use old SSL port method”

I hope this works - I dont’’ want to be bronze the rest of my life…

The actual solution was a very bonehead mistake that I overlooked, which I must say I am too embarrassed to admit. But on the upside, I wouldn’'t have known to use the old port method…

Thank you,