Import Ejabber-Data

Good morning ,

a friend of mine is thinking about a change from ejabber to Wildfire.

But the problem why he is hesitant to do this, is that there are a lot of user to transfer.

Is there any simple way (import or whatever) to change and keep all the existing users ?

Hi Finn,

Good to hear your friend is considering Wildfire.

If you would like I can pass along to you a perl script that formats ejabberd data into an xml file that can then be imported into Wildfire using the url= Import/Export plugin[/url]. The perl script was actually given to me by another url= member[/url] since I was the one who developed the plugin. I have not had a chance to try out the script so I think it would be great hear from people who can try it out and report back what they find. At some point soon I’'d very much like on a suite of tools, scripts, plugins, etc., to help people move from some of the other IM servers to Wildfire.



Hi Ryan,

would be great if you could send the script to the address given in my forum-profile.

I will pass it to my friend so that he can test it and will report later how it worked.



Hi everyone,

just a little status report:

Ryan has been so nice to send me the script and nearly everything went fine except for the passwords. But we are searching for the problem and will put the fixed script here when its done.


Would you be interested in sending me the fixed version?

(I’'m also wondering if you all have the latest version of it or not)

Either way, I’'ll be making it available on at some point.

I’'m interested in that script, too.

I’'m considering moving from ejabberd to wildfire, but I would like to make that transition to my users as transparent as it can be…

ejabberd version is 1.1.1, if that is important…

thank you.

Message was edited by: tnt

I my latest version available at:

Thank you.

I tried to migrate my only user this way and I found that it had problems with my vCard and it seemed to be the avatar. I solved it the easy way by clearing vCard using a client and then dump the database again. Then I found that it had problems with bookmarks but since my client has no GUI to manage bookmarks I just deleted them from the dump file.

After import and restart of the server (I had been running a test domain for a while) everything worked fine.