powered by Jive Software

Imported DB and now I cannot login with Admin account (or backend at all)

Ok guys here is my situation. I currently have a server setup with Microsoft Sql 2008 and Openfire 3.6.4. This is considered an upgrade so i have imported the entire Database into the new box. When installing Openfire I had no issues with authentication or setup during installation. IN FACT i can login with the newly used Spark server with my old usr/pass. The issue remains when i attempt to login to the backend (http://localhost:9090/login.jsp) and receive a “Login failed” with ANY user with admin rights or even the Admin itself.

**What is strange is i can physically login with the “admin” via the chat client but when attempting to login in the backend, i cannot… I have reinstalled and performed the setup several times with the EXACT same result… Help?

Did you try http://www.igniterealtime.org/community/thread/41330#201653 ?

Yes i have tried that step. The value is not present in my “Openfire.xml” as i believe that step is geared towards Mysql. Im currently using Sql server 2005.

Hi,

your openfire.xml file should contain at least a “jive” section, and there you can add the “admin” part.

<?xml version="1.0" encoding="UTF-8"?>
<jive>
    <admin>
        <authorizedJIDs>admin@example.com</authorizedJIDs>
    </admin>
    ...
</jive>

LG

Im still unsuccessful. see the attached image. Whenever i place that code into the proper position it is immediately removed when I start the Openfire server. When i try to login with ANY user given the “authenticated” mode it responds the same “Login failed”.

**The atached image also shows my code and that i can successfully login with the “Admin” account from the client side(or any admin privileged account). Is there a simple way to reset the Admin password in Sql server 2005?

***There is another strange aspect. When i run the setup over again and opt to change the “Admin” password it takes effect ONLY on the client side.

Hi,

I assume that you did replace “example.com” with your XMPP domain name. During startup Openfire reads the openfire.xml file and should write this information into the OFPROPERTY table. There you may want to look for the value of “admin.authorizedJIDs” - it should match your admin JID. If it does not you may want to stop Openfire, edit the value and start Openfire again.

As you can login it makes little sense to reset the password. If you still want to do this you need to edit the OFUSER table. The 1st column is the username, the 2nd the plaintext password and the 3rd the encrpyted password. Set the encrpyted password to NULL and set a plaintext password for “admin”.

LG

Again thank you for the quick response. I followed the steps and indeed changed the value to plain text. I WAS able to login via the Spark client but NOT able to login through the back-end. I tried this on the “admin” as well as a known user with admin* privileges. I did consult our Db admin and was suggested to ask where the Admin back-end connection string resides to verify everything is correct. *

**When this is resolved I feel compelled to buy you a beer hahhaa

Hi,

the admin console http://server:9090/ uses the same credentials as every XMPP connection. So as soon as you use the proper admin JID everything should work fine. I wonder whether you your xmpp.property value (also in OFPROPERTY) matches your JID.

So xmpp.domain=example.com and admin.authorizedJIDs=admin@example.com should work fine.

LG

Well i have an update. I was still not able to attach the imported DB and use it. I had to create a brand new DB and start from scratch. The odd thing was even after i created a fresh DB and new installation of Openfire i was STILL not able to login to the backend UNTIL I rebooted. I thought this was a sign of hope and attempted one last time with the imported, which failed. I have to sum this up to a bug. Luckily the Openfire Import/export plugin saved me from inputing every user/group. Again thank you for your help and your patience.

That last part is a know bug (I swear nobody reads the announcements). If you want to use your old db do this. Import it again with openfire off. Then edit the openfire.xml setup tag to read false. Start openfire goto admin page and step through the config entering all the original values again exactly as they were originally. When done reboot the server.