powered by Jive Software

IncomingFileTransfer has "receive" misspelled as "recieve"

I noticed that the IncomingFileTransfer class has two methods named recieveFile. The receive portion of the method is misspelled. I know that it is a public interface and thus changing the spelling would break code in production using the class. Can we potentially deprecate the misspelled method name and make receiveFile the new method signature to use? Is this an option?

Paul already took care of that in https://github.com/igniterealtime/Smack/commit/8bd3856fa1613721aee1f32a004c8a9b79b9a7b8

Although it seems that the old method was not deprecated, if you care about it.