powered by Jive Software

Increase Java heap space

Hi friends :

I built 100.000 users on Sql server for test Openfire and I added then to e group.

Now, when I click on group, I see this error : java.lang.OutOfMemoryError: Java heap space…

I did belows for solution of error, but It did’nt change the Openfire.

(I installed Openfire on Win7)

…If you use OpenFire as a service configured in Windows, create a file with the openfire-service.vmoptions name and place within it the following parameters one below the other as they are.
-Xms512m
-Xmx1024m

Thanks.

1024 might be not enough for 100k users. If you don’t mind using alpha versions, you might give this a try (x64 version with x64 Java) https://bamboo.igniterealtime.org/artifact/OPENFIRE-NIGHTLYWINDOWS/shared/build- 2514/Project-Windows-distribution-files/…

Btw, if you have created openfire-service.vmoptions, then you should run Openfire with a service (not with launcher). And when using x64 Java try setting it like

-Xms1024m
-Xmx2048m

then try increasing the Xmx by 1 GB (depends on how much RAM your system has).

Thanks to your responding.

I installed that version you said and I placedthe file of openfire-service.vmoptions with its

-Xms1024m
-Xmx2048m

content.

the image before placing the file of openfire-service.vmoptions

before.png

the image after placing the file of openfire-service.vmoptions

after.png

  1. Have done the changes accurately?because min space and using percent changed but the general space is 878.50MB yet.

  2. What did you mean when you said “you should run Openfire with a service (not with launcher)”?

  3. What should I do for changing X64 java (increasing Xmx) setting?

  1. It hasn’t changed as you probably a) not actually using the service, b) have it as openfire-service.vmoptions.txt and not as vmoptions file. Make sure the extension is right.

  2. I mean you should run it with its Windows service. You don’t know what a service is in Windows? If you are running Openfire with a launcher it won’t pick up the vmoptions file which is for the service.

  3. 1-2

I don’t have any problem about extension but I don’t know the service of open fire.I stop/start it with web admin.

  1. What is the name of that service?

  2. Does solve its problem with restart that service?

Thank you.

Press Start, type services. Open the Services applet. It is called Openfire. That vmoptions file is for this service. If you are running Openfire via launcher, stop it, close it and never use it. Then start the service. To login to Admin Console just open the browser and go to http://localhost:9090 (or https://localhost:9091 for SSL). It should pick the new settings from vmoptions file once you run it via service.

Thanks wroot, I think resolved

Java Memory



189.00 MB of 1820.50 MB (10.4%) used