powered by Jive Software

Initializatoin of Plugins take time, Hourglass cursor missing at startup

Hi

We observe a weekness with Spark, which perhaps other also can see. We are unsure if we should report this as a bug, but first we will describe it here in this forum.

During startup of the Spark client, it takes some time to initialize the plugins. During this time, it is possible to interact with Spark (no Hourglass cursor - protection). I have been able to open at ChatRoom before the ‘‘Emoticons’’ plugin is loaded, with result that the emoticons are not present in the editorToolBar…

I beleive other has seen this ?

We have 2 options:

  • fix the problem in the soirce, and rebuild the jar files before installing the client at our PC’'s. We hope not to do this, since it will make upgrading to later versions more troublesome.

  • report this as a bug? and hope it is fixed iin next version.

Any suggestions ?

Regards

Per Kåre Foss

Hi,

which Spark version are you using?

If it’'s not 2.5.0_beta4 then it will help a lot to know if you see this problem also with this version.

LG

Hi!

We are using the lates “official” 2.0.8 afaik. Running on Windows XP platform.

We have build 2 plugins ourselves, which now is in accaptence test, sp we can not upgrade to the Betha (and I doubt we will be allowed to) just now. But if you can not see the same behaviour with 2.5.x then it is worth to try that for the next internal updrade.

Regards

Per Kare Foss

Hi,

you can install Spark 2.5 also to another directory, for example c:\temp to test it. The xmpp: link may be updated in the registry so Spark 2.5 launches if you click such a link but your normal Spark 2.0.8 startup link should still work fine.

LG

created SPARK-670

I am happy it is reported as a bug.

We have the same behavior with 2.5.8

Regards

Per Kåre Foss

StatoilHydro