powered by Jive Software

Instability of the JitsiVideoBridge

Hello,

I think this is right to feedback about stability of JitsiVideoBridge.

I tested JitMeet with 5 persons during two hours and we have so many problems:

1 - So difficult to connect to shared link. Some users connected ok, others need so many refresh to url and so on. Some times trying close chrome and start again and nothing. Some times more than 50 times refreshing page/clicking in url link to enter in room.

2 - Some people get out room or congeals the image. And when people try to connect again, really can’t. Trying many many times to enter back to room and nothing. Some times works. Some times I need to create again a new room or wait a magincal time to enter again on room. I tryed to restart openfire too.

3 - When a person is simply disconnected by JitMeet/videobridge and are trying to back to room, in working room for other people, show many times the litte image on bottom of the same person that are trying to connect.

4 - But when don’t happen thats problems above, works fine. But this above is very very problematic. I think that is not possible to use in production.

Environments:

Server: Ubuntu 13.10 64bit + openfire 3.9.1 + jitsivideobridgeplugin 1.2

Bandwidth: 100Mbps full duplex.

Clients connected to jitMeet: two using windows, one using linux, and two using android (android beta). I tryed all tests without use android. Just 5 PCs and problems is the same.

Bandwidth: All person doing the tests has up of 10Mbps (full dupplex).

5 - I would like to know about this problem with stability/unstable system and if are you are working on with a stable version?

6 - I would like to know too if problem with stability of system is just videobridge or is openfire/JitMeet parts?

I’m attaching the stderror.log compacted (stderror.tgz) with all my logs. May be can help you about check problems with the stability.

If you need, I can to do any more tests. Just tell me what type of tests you needs.

Thank you so much.

Beyonlo.

<iq type=“result” id=“3:sendIQ” from=“jitsi-videobridge.65.111.165.20" to="82ce8b71@65.111.165.20/82ce8b71”>

Please note it does not work properly with an IP address. Use a fully qualified domain name

Hello Dele.

I did all changes of IP Address to domain name (including that part of openfire installation web - Everything was reinstalled), but problems of instability still exist. Today I did tests more time with ofmeet than jitmeet. Anyway, today in one hour of tests with 3 person I have more problem than yesterday with 5 persons and with wrong setting - IP address.

But problems of today are a bit different: people enter in room but they show for me just a black window and for other people my image is black too. We refresh browser many times and nothing. Some times image is showed in OfMeet, some times not.

I always check the messages of stderror.log and today errors show more than yesterday.

I attached the log file just tests today.

Thank you.
stderror.tar.gz (182847 Bytes)

I can confirm the instability on longer lasting sessions with Openfire 3.9.1 and JitsiVideovBridge 1.2, although I did not this in-depth testing as Beyonlo.

Hello Dele,

Could you help us?

What are we doing wrong, are there a special configuration? If yes, told me what exactaly we need to do to have a stable Jitmeet/OfMeet with openfire + videobridge.

Thanks so much.

Hi,

i did some tests too and I found that it is not possibile to change the standard https port (7443) to another one as I would need.
Furthermore I can properly join the room and share video with candy app (no screenshare) but both jitmeet and ofmeet did not let me do anything.

I do only see a blue bar in the top of the browser window and a gray square “profile icon” in the bottom even if the room is not moderated has no password and someone is already in.

Do you have any suggestion?

Regards

Here there is a snapshot of my ofmeet session, has anyone an idea on what’s going wrong?

Hi Giorgio,

please active the Chrome console with CTRL-SHIFT + J and paste the error you see when try to access to the page.

Regards

Thanks for the fast answer, here there is the result:

Uncaught ReferenceError: webinstant is not defined config.js:3

This appears to be Chrome main.js:303

Uncaught TypeError: Cannot read property ‘useWebsockets’ of undefined

i’m going to check the first error even if it seems to be ok…the usewebsocket should be enabled but where?

Rechecked cannot find any error apparently, here there is my config:

var config = {

hosts: {

domain: webinstant.datamanagement.it,

muc: ‘conference.webinstant.datamanagement.it’, // FIXME: use XEP-0030

bridge: ‘jitsi-videobridge.webinstant.datamanagement.it’ // FIXME: use XEP-0030

},

useIPv6: false, // ipv6 support. use at your own risk

useNicks: false,

useWebsockets: true,

resolution: “360”,

bosh: window.location.protocol + “//” + window.location.host + ‘/http-bind/’ // FIXME: use xep-0156 for that

};

G. Catena

Hi Giogrio,

you see any error on the chrome console?

Regards

No, only what I wrote down before.

Regards

Hi Giorgio,

I can access to your application and working fine on my Chrome. I use this URL:

https://webinstant.datamanagement.it/jitsi/apps/ofmeet

Regards

thanks dele found the error…

i’ll tell you what is is in another life…let me say it could be addressed as a…rookie error !!!

Hi Giorgio,

now that your application work, can you share the configuration to use 443 port instead the default 7443.

Thank you or Grazie

Regards

hi, i just resolved the problem on the websockets error and url match, nope to have the correct link opened by the spark plugin. It keeps pointing to the 7443 port instead of the https standard one (443).

I think that dele could help to resolve this, it would be really useful for me.

Regards

I did find a C.bat inside the path related to the classes and there there is the compile method used:

“C:\Program Files\Java\jdk1.6.0_43\bin\javac” -Xlint -classpath .;…\smack.jar;…\smackx.jar;…\spark.jar org\jivesoftware\spark\plugin\jitsivideobridge*.java

I find out the classes that cointain the port 7443 that is:

private String port = “443”;

in row 49 of the JitsivideobridgePlugin.java file

I could recompile everything but i do not have the proper classes (smack.jar, smackx.jar and spark.jar

Would it be possibile to place the port as a parameter or take it from the of bosh setup?

Regards

Hello Dele,

Could you tell me about instability of videobridge/ofmeet?

I have all working, but it is unstable like as I describe in details above. Other person write the same problem too above.

Could you tell me if is really bugs/unstable system, and if yes, what we need to do or just to wait for a new release?

Thanks,

Hi Giorgio!

For the port 7443 vs 443 problem I just use Apache mod_proxy:

SSLEngine On
SSLCertificateFile "/etc/ssl/certs/ssl-cert-snakeoil.pem"
SSLCertificateKeyFile "/etc/ssl/private/ssl-cert-snakeoil.key"
SSLProxyEngine On
ProxyRequests Off
ProxyPreserveHost Off
ProxyPass /http-bind/ http://jabber.example.com:7070/http-bind/
ProxyPassReverse /http-bind/ http://jabber.example.com:7070/http-bind/
ProxyPass /ws/ https://jabber.example.com:7443/ws/
ProxyPassReverse /ws/ https://jabber.example.com:7443/ws/
ProxyPass /jitmeet/ https://jabber.example.com:7443/jitsi/apps/jitmeet/
ProxyPassReverse /jitmeet/ https://jabber.example.com:7443/jitsi/apps/jitmeet/
ProxyPass / https://jabber.example.com:7443/jitsi/apps/ofmeet/
ProxyPassReverse / https://jabber.example.com:7443/jitsi/apps/ofmeet/

At least this does work for me for ofmeet. Don’t know whether this is good practice or just an evil hack. For the other applications in jitsivideobridge you need to add the matching entries as well, of course.

create a file called

USER_HOME\Spark\jitsivideobridge.properties

on your PC that is running Spark and enter

port = 443

protocol = https

server = your_server_name

If you look at the source code, it uses these three properties to create the URL

url = protocol + “://” + server + “:” + port + “/jitsi/apps/ofmeet/?”;

on windows, USER_HOME would be your user folder (C:\USERS\XXXX)