powered by Jive Software

Install Help

The install documentation is relatively sparse and looks like it should “just work.” I’'ve run into a couple of problems with my install on CentOS 4.4 though.

I ran the redhat script that should install wildfire as a service, and wildfired does not start at startup even though the output of chkconfig suggests that it will. I have to manually start it.

I can load the setup wizard and see the pick language screen. After selecting English and clicking continue, I get this error the following error…any idea what to do next?

HTTP ERROR: 500

wildfire: wildfire

RequestURI=/setup/setup-host-settings.jsp

Caused by:

java.net.UnknownHostException: wildfire: wildfire

at java.net.InetAddress.getLocalHost(Unknown Source)

at org.jivesoftware.wildfire.admin.setup.setup_002dhost_002dsettings_jsp._jspServi ce(setup_002dhost_002dsettings_jsp.java:132)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:491)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1074)

at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:11 8)

at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:65)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:41)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.jivesoftware.admin.PluginFilter.doFilter(PluginFilter.java:69)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:98)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:365)

at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:185)

at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)

at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:689)

at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:391)

at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollect ion.java:146)

at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)

at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)

at org.mortbay.jetty.Server.handle(Server.java:285)

at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:457)

at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.j ava:751)

at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:500)

at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:209)

at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:357)

at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:329)

at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:475)

Hi,

reading http://wiki.igniterealtime.org/display/WILDFIRE/LinuxInstallationGuide may help.

Interesting parts which may match your problems:

“Make sure that the unix command “hostname” returns a valid name, for example “mycastle” and that your /etc/hosts file does contain this name, for example in the first line together with “127.0.0.1 localhost mycastle”. Or that you can resolve it using DNS. Actually the setup page after choosing your locale settings will return a HTTP 500 error if there is a problem.”

"# install new rc scripts

  1. adjust S20wildfired and K80wildfired to your needs. if you run another database

  2. and want to use it with Wildfire then make sure that the database is started

  3. before Wildfire and shutdown after it.

  4. With S20 Wildfire is started very early, it’'s fine for the embedded database."

LG

Hey John,

Thanks for the bug report. I will make some changes to Wildfire to recover from this exception. Anyway, the root problem is that Wildfire is trying to resolve wildfire to get it’'s IP address and nothing is found. I would say that something has to be changed in your network setup in your unix box.

Regards,

– Gato

That explains a lot. Thanks. I’‘m still waiting on the group that manages DNS to get the hostname registered for my machine. I figured I’‘d start playing until then. I guess there was no good clean way to say "sorry, I can’'t resolve your IP" so I found the error confusing.

Hey John,

I filed JM-987 and checked in a fix for it. You may grab the code from SVN and build Wildifire by running ant wildfire in wildfire/build. Or you can wait for tomorrow and use the nightly build version that includes the bug fix.

Regards,

– Gato