powered by Jive Software

Install OpenFire as a service, JVM setting is not active

Hello, Every one:

I install openfire as a service, and I created the config file “openfired.vmoptions” as below:

-Xms256m

-Xmx256m

when I start openfire with the system services “openfire”, it’s JVM setting is 64M?? (every time)

But if I start it with the openfire.exe , it’s JVM setting is 256M.

can you help me?

thanks.

Hi,

http://www.igniterealtime.org/builds/openfire/docs/latest/documentation/install- guide.html reads:

Custom Parameters

Advanced users may wish to pass in parameters to the Java virtual machine (VM) to customize the runtime environment of Openfire. You can do this by creating vmoptions files in the bin/ directory of your Openfire installation. For the Windows service, you’d create a new text file called openfire-service.vmoptions.

LG

It’s OK now , thank you very much!