powered by Jive Software

Install Openfire-No-JRE-Bundled package issue

Hi there,

I got a problem when I tried to install Openfire(no JRE bundled) on CentOS with OpenJDK. OpenJDK has been installed on server, but when I run the Openfire install command I got a error message:java >= 1:1.8.0 is needed by openfire-4.4.1-1.noarch. Below is the OpenJDK information:

anyone has any ideas?

Thanks,
John

What CentOS version? I think i have tried once in a VM with a latest version and default OpenJDK. I think it was Java 11. I can check my VM later. Do you need Java 8 for something else on this system?

Please report the RPMs installed for java and also, why are you relocating the install?

My test was on CentOS 7 1810 (now updated to 1908, still works). I have installed minimal install, then installed java 8 with: yum install java-1.8.0-openjdk-devel
java -version shows similar to your, but no that Zulu stuff., maybe that’s the case.
That was actually still with 4.3.2 version. Now i have updated via:
rpm -Uhv openfire-4.4.1-1.noarch.rpm
After the update it didn’t work at first (it is weird that it first shows updating and then cleaning up old version, but maybe that’s how rpm usually works). systemctl daemon-reload didn’t work either. So i have rebooted the server and now it works. 4.4.1 with Java 8.

@akrherz @wroot, appreciated your reply!

@akrherz, our team run the Openfire on CentOS with Oracle JDK, and now we need to repalce the Oracle JDK with OpenJDK for some business reasons.

@wroot, the OS version, please see below:
image

I cannot run the yum on this OS since the security plicy limitation of company. I will get the oracle openjdk and try it again the way you provided.

Thanks guys!

It probably doesn’t matter very much, but you can get an exact version with:
rpm --query centos-release

I don’t think Oracle’s OpenJDK is required. Should work with any OpenJDK (i have tried AdoptOpenJDK on Windows). Also, you can try latest Java 11 version instead of 1.8.0, if you don’t specifically need Java 8 for something. I used Java 8 first because 4.3.2 didn’t support Java 11. But 4.4.x versions do now.

This is still not clear why are you relocating Openfire’s install.

@wroot, thanks for your message!
Sorry for not very family with Linux and the exact OS version is: centos-release-7-6.1810.2.el7.centos.x86_64.

Here is the backgroud about:
Beacuse Oracle JDK is not free anymore since Jan 2019, so the company decided to replace the Java from Oracle JDK to OpenJDK, Openfire(now running 64bit JRE bundled) is included.

For this, we need to uninstall the JRE bundled version and install no JRE bundled one, right? Before that, we have to install OpenJDK first and when those steps are done, we’ll check if the Openfire no JRE bundled with openJDK is still working.

BTW, I have tried openJDK 11 with Openfire 4.4.1.noarch before, still got the same error message I mentioned it. Java 8 is not necessary.

I just want to figure out what is the root case for “java >= 1:1.8.0 is needed by openfire-4.4.1-1.noarch” when installing Openfire or if I just misunderstanding about Openfire between the diff versions and then did the incorrect operations for my purpose.

Thanks,
John

Java included in Openfire has not been updated since it becoming not free anymore. So, maybe it is still ok to use. Although there are plans to get rid of bundled versions completely, so you still will have to move to using not bundled version in future.

I’m not that experienced with Linux and CentOS myself. I haven’t tried to install java without yum. Maybe @akrherz can give you a command to show package info that he asked for. It might be that java install is not correct.

Also, you may try to just delete the jre folder in the current installation folder. Instead of relocating you can try doing uninstall and then installing new version. But first you need to figure out this java error.

I got an airticle before Install openfire on CentOS Linux 7.0.1406 (Core) answered by @akrherz. So, I think the steps I listed in the previous comment are correct. But why still got the error messages after installed openJDK when I try to install Openfire with noarch version? It make no sense unless there are some dependencies between them missing. Also, I just unziped openJDK .tar.gz file to the directory and set the java home with the path and saved it in the /etc/profile not like install the openJDK by yum command.

I will look into this further and really appreciated what you did @wroot.

Thanks for your time,
John

@wroot, @akrherz the Openfire is running now. I will record how this problem be resolved in my situation tomorrow since it’s too late now in china to leave office and go home. Anyway, thanks guys for your help!

Good day,
John

1 Like

Job’s done. The best way to resovle the problem is found the reason why yum is invalidation on the related OS, then run the command install openJDK and Openfire. Thanks!

1 Like