powered by Jive Software

Installation Failure

Hi,

Have been trying to install Openfire 3.8.1 onto an Ubuntu 12.04 server. To satisfy the java requirements I did

apt-get install default-jre

Then when running the following, I get no errors.

sudo dpkg -i openfire_3.8.1_all.deb

I go to the setup page, and select the default Server Settings, and Embedded Database on the Database page.

I select LDAP server and then use the following settings to connect to the LDAP server, which is a Zimbra box.

Server Type: Open LDAP

Host: 10.11.12.5

Port: 389

BaseDN: uid=admin,ou=people,dc=domain,dc=com

Admin DN: uid=zimbra,cn=admins,cn=zimbra

Admin Password ( zmlocalconfig -s | grep -i LDAProotPassword --> password)

I then sit there pressing the test button, and nothing happens. No confirmation or denial. If I proceed, I get to the bit where I add users, and all I can do is add admin. It fails to allow me to add any of the users in the LDAP directory.

Nothing much in the logfiles. info.log says

2013.04.10 15:50:37 org.jivesoftware.openfire.XMPPServer - Openfire 3.8.1 [Apr 10, 2013 3:50:37 PM]

2013.04.10 15:50:39 org.jivesoftware.util.cache.CacheFactory - Created cache [org.jivesoftware.util.cache.DefaultLocalCacheStrategy] for Favicon Misses

2013.04.10 15:50:39 org.jivesoftware.util.cache.CacheFactory - Created cache [org.jivesoftware.util.cache.DefaultLocalCacheStrategy] for Favicon Hits

2013.04.10 15:50:39 org.jivesoftware.openfire.container.AdminConsolePlugin - Admin console listening at http://127.0.0.1:9090

2013.04.10 15:50:57 org.jivesoftware.util.cache.CacheFactory - Created cache [org.jivesoftware.util.cache.DefaultLocalCacheStrategy] for User

2013.04.10 15:50:57 org.jivesoftware.util.cache.CacheFactory - Created cache [org.jivesoftware.util.cache.DefaultLocalCacheStrategy] for Remote Users Existence

2013.04.10 15:51:25 org.jivesoftware.database.SchemaManager - Missing database schema for openfire. Attempting to install…

2013.04.10 15:51:25 org.jivesoftware.database.SchemaManager - Database update successful.

All other logs are blank. The embedded-db directory only holds two files openfire.properties and openfire.script, so it looks like the database is never created.

I have removed (apt-get purge openfire) and reinstalled it 20 times. I have tried with different browsers (Firefox and Chrome), I have tried sneaking up on it and catching it by surprise. Nothing. Any ideas? Can I supply more information?

OK, lets break this down.

What am I meant to see in the embedded db directory? Does two text files seem like the right thing to see in there? How can I test if the database has been created?

OK, so it seems that the database actually is /usr/share/openfire/embedded-db/openfire.script

Amazing.

So that’s not the problem then. So it must be the LDAP settings. But as there’s no feedback on the so called “Test” its a case of trying different strings and carrying on until one works, purging and reinstalling openfire until I get one that does. Fairly sure its something to do with the DN entries then.

Hmmm.