powered by Jive Software

Installation Issues

Hey,

I’'ve installed OpenFire using the RPM (on CentOs 4.4) and it seems to work, however I have two issues so far.

openfired doesn’'t seem to exist (not anywhere)

and I can’'t access the admin panel away from the server, and my only access is SSH so I currently have to use lynx

Hope you guys can help

Thanks in advance

Message was edited by: D4rkDrago0n

There is no openfired. If you look at the running processes, it will be running as the java process. I think the rpm installs into /opt/openfire so check there. Second, if you have ssh access, try this from your system (not the server)

ssh -L9090:localhost:9090 servername

Putty and other GUI ssh clients should have similar options for forwarding ports.

This will forward port 9090 to your local computer, so you can open up a web browser and go to http://localhost:9090 to access the admin page.

Yeah, I’'ve installed it and run openfire.sh which allowed me to set up the settings through lynx. But all of the tutorials to have it run as a daemon require a script called “openfired” in /bin/extras.

Are they just outdated?

and sorry, but I can’‘t figure out how to do the SSH port forward with PuTTY (I’‘m a bit of a newb with SSH). At the moment I’'m running windows. I could switch to linux If absolutely necessary.

Hi,

maybe the rpm installer already creates a file /etc/rc.d/init.d/openfired as one would expect it.

On Windows / Putty you’'ll need a current version of Putty and there you should find: Connection, SSH, Tunnels

LG

Yeah, theres openfire in there but no openfired

when I run openfire it holds the entire SSH session unlike a service/daemon that would load, display messages and then release the terminal.

And I see it, but I don’'t fully understand how it works,

As far as I can figure, I put localhost:9090 in source and set it the mode to remote but I can’'t tell what to put into the destination box.

Sorry If I’'m frustrating :stuck_out_tongue:

Right, the SSH tunneling is working.

Now I just need to know how I can either create “openfired” or to get “openfire” to run as a daemon/service.

Hi,

the openfire.sh script should start Openfire as a daemon. Using the RPM installation you should already find scripts in the rc directories to start Openfire. If you miss them and want to create them manually take a look at http://wiki.igniterealtime.org/display/WILDFIRE/LinuxInstallationGuide

LG