powered by Jive Software

Installed fine, but doesn't work

Hi

I tried it now a couple of time, but either there is a bug, or I’m just too stupid (Layer 8 Error).

Everything works fine, even the gateway installation. I then created a user, but no matter what client I use (iChat, AdiumX), it’ll never accept my password, i.e. doesn’t log me in …

Anything I can do / look for?

There is nothing at all in the error log

Thanks

f0r42

don’t kn ow what I did, but at least I can login now.

I’m logged in via adiumX and iChat from the same machine, but my session doesn’t get listed and through adiumX I can’t see the gateway services …

Anyone with a helping hand?

f0rd42

bizarr … I can basically log in from anywhere (ichat, AdiumX, iPhone), but don’t see this session on the server.

I restarted the server (/etc/init.d/openfire restart) and can’t login anymore (as admin or as a user I created with admin rights)

I furthermore get the following in the error log:

2009.03.22 13:18:33 [org.jivesoftware.openfire.filetransfer.proxy.ProxyConnectionManager$1.run(Prox yConnectionManager.java:92)] Error creating server socket

java.net.BindException: Address already in use

at java.net.PlainSocketImpl.socketBind(Native Method)

at java.net.PlainSocketImpl.bind(Unknown Source)

at java.net.ServerSocket.bind(Unknown Source)

at java.net.ServerSocket.(Unknown Source)

at org.jivesoftware.openfire.filetransfer.proxy.ProxyConnectionManager$1.run(Proxy ConnectionManager.java:89)

at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)

at java.util.concurrent.FutureTask.run(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

2009.03.22 13:18:34 [org.jivesoftware.openfire.spi.ConnectionManagerImpl.createServerListener(Conne ctionManagerImpl.java:153)] Could not setup a server socket

java.net.BindException: Address already in use

at java.net.PlainSocketImpl.socketBind(Native Method)

at java.net.PlainSocketImpl.bind(Unknown Source)

at java.net.ServerSocket.bind(Unknown Source)

at java.net.ServerSocket.(Unknown Source)

at org.jivesoftware.openfire.net.BlockingAcceptingMode.(BlockingAcceptingMod e.java:35)

at org.jivesoftware.openfire.net.SocketAcceptThread.(SocketAcceptThread.java :57)

at org.jivesoftware.openfire.spi.ConnectionManagerImpl.createServerListener(Connec tionManagerImpl.java:144)

at org.jivesoftware.openfire.spi.ConnectionManagerImpl.createListeners(ConnectionM anagerImpl.java:84)

at org.jivesoftware.openfire.spi.ConnectionManagerImpl.start(ConnectionManagerImpl .java:826)

at org.jivesoftware.openfire.XMPPServer.startModules(XMPPServer.java:569)

at org.jivesoftware.openfire.XMPPServer.start(XMPPServer.java:434)

at org.jivesoftware.openfire.XMPPServer.(XMPPServer.java:161)

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)

at java.lang.reflect.Constructor.newInstance(Unknown Source)

at java.lang.Class.newInstance0(Unknown Source)

at java.lang.Class.newInstance(Unknown Source)

at org.jivesoftware.openfire.starter.ServerStarter.start(ServerStarter.java:106)

at org.jivesoftware.openfire.starter.ServerStarter.main(ServerStarter.java:51)

2009.03.22 13:18:36 [org.jivesoftware.openfire.spi.ConnectionManagerImpl.startServerListener(Connec tionManagerImpl.java:172)] Could not setup a server socket

java.lang.NullPointerException

at org.jivesoftware.openfire.spi.ConnectionManagerImpl.startServerListener(Connect ionManagerImpl.java:163)

at org.jivesoftware.openfire.spi.ConnectionManagerImpl.startListeners(ConnectionMa nagerImpl.java:126)

at org.jivesoftware.openfire.spi.ConnectionManagerImpl.access$000(ConnectionManage rImpl.java:54)

at org.jivesoftware.openfire.spi.ConnectionManagerImpl$1.pluginsMonitored(Connecti onManagerImpl.java:108)

at org.jivesoftware.openfire.container.PluginManager.firePluginsMonitored(PluginMa nager.java:533)

at org.jivesoftware.openfire.container.PluginManager.access$800(PluginManager.java :47)

at org.jivesoftware.openfire.container.PluginManager$PluginMonitor.run(PluginManag er.java:1042)

at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)

at java.util.concurrent.FutureTask.runAndReset(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknow n Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

2009.03.22 13:18:36 [org.jivesoftware.openfire.spi.ConnectionManagerImpl.startClientListeners(Conne ctionManagerImpl.java:359)] Could not setup a server socket

java.net.BindException: Address already in use

at sun.nio.ch.Net.bind(Native Method)

at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source)

at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)

at org.apache.mina.transport.socket.nio.SocketAcceptor.registerNew(SocketAcceptor. java:363)

at org.apache.mina.transport.socket.nio.SocketAcceptor.access$800(SocketAcceptor.j ava:55)

at org.apache.mina.transport.socket.nio.SocketAcceptor$Worker.run(SocketAcceptor.j ava:222)

at org.apache.mina.util.NamePreservingRunnable.run(NamePreservingRunnable.java:51)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

2009.03.22 13:18:36 [org.jivesoftware.openfire.spi.ConnectionManagerImpl.startClientSSLListeners(Co nnectionManagerImpl.java:472)] Could not setup SSL socket

java.net.BindException: Address already in use

at sun.nio.ch.Net.bind(Native Method)

at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source)

at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)

at org.apache.mina.transport.socket.nio.SocketAcceptor.registerNew(SocketAcceptor. java:363)

at org.apache.mina.transport.socket.nio.SocketAcceptor.access$800(SocketAcceptor.j ava:55)

at org.apache.mina.transport.socket.nio.SocketAcceptor$Worker.run(SocketAcceptor.j ava:222)

at org.apache.mina.util.NamePreservingRunnable.run(NamePreservingRunnable.java:51)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

f0rd42

ok, forget the last one … this was ejabberd which hasn’t been removed properly …

No, I’m back zo my original problem … I can’t login, as it doesn’t accept my password … (but I can login with that user / password in the admin console )

f0rd42

Hi,

it should work. Do not user upper case characters in the JID as this could cause trouble. Try ASCII only passwords to make sure that your clients have no problem with UTF-8 characters. Try to login as “admin” in the web UI and create a user “a” with password “a”.

Did you create new (self-signed) server certificates after installing Openfire?

Do your clients accept these certificates?

Do you specify the right xmpp.domain (which is likely not the hostname of the server) to login?

Do you have a DNS record or an entry in your /etc/hosts file for you xmpp.domain?

LG