powered by Jive Software

Installed Openfire on RedHat Server - Spark Client can't find server

Good day.

I have installed openfire on a redhat server. I used the ‘basic’ method of installing - no external database & no LDAP.

I currently cannot connect my spark client (from another machine) to the openfire server. I also cannot get to the admin console from another pc. However, I am able to log in with spark on the server using localhost as server and admin console using 127.0.0.1:9090.

Here are a few questions that may help troubleshoot:

  1. Should the **Server Name **be the same as the server’s Host Name?

  2. Does it matter that the server and clients are on different subnets? i.e. server: xxx.xxx.xx.xx **client: **xxx.xxx.yy.yy

  3. On the spark client, under Server should I type the Server Name or Host Name (if they are different)?

For what it’s worth, I’ve tried:

  • different combinations in the **server **field

  • manually pointed the client to the server’s IP Address.

  • checked, and verified that ports are open on server

  • changed the **server name **field on openfire from servername.domain.com to servername

TYIA,

lAresl

Hello

my friend cheking username and password for root : conecction database and edit file /etc/hosts in Gnu linux my hosts conf hhehehe

#eth1

192.168.1.104 cuentaconmigo.pe chat.cuentaconmigo.pe localhost4 localhost4.localdomain4

#eth0

192.168.1.103 cuentaconmigo.pe chat.cuentaconmigo.pe localhost4 localhost4.localdomain4

127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4

::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

and chane hostname is you ip static private local network in my case is 2 networks cards 192.168.1.104

accces from others pc 192.168.1.104:9090

thanks

El mensaje fue editado por: Jhon

Thank you for the ideas Jhon.

The database I’m using is just the one that came with openfire. Permissions should be fine as I can create other users/accounts using the admin console AND the spark client on the local server.

I have tried using the IP address to connect to the admin console (xxx.xxx.xx.xx:9090) but it does not work either.

Here are some more questions:

  1. Are there router settings that have to be changed to allow XMPP protocol?

  2. Are there router settings that have to be changed to open port 5222?

Thanks,

lAresl

If the server and the client are on different subnets; do the two networks that know about each others subnet and comunicate fully or is there NATing between the two. If you are NATing, have you confiqured port forwarding into the server on 5222 and 9090 or 5223 and 9091 for secure communication??

One of our other tech guys found out that /etc/sysconfig/iptables had to be modified to enable ports 5222 and 9090.

We were replying at the same time…

Please find the solution to my problem below.

Thanks,

lAresl