powered by Jive Software

Installing as a service

When I run the server as a stand alone app, it works wonderfully now, but I am still having some issues installing it as an NT service. I have set JAVA_HOME to my jdk directory as well as trying the other suggestions in the manual, but so far no go. The service installs correctly, but when I start it, it immediately errs off and quits. Here are the error messages I am getting in the wrapper log:

STATUS | wrapper | 2004/09/30 11:37:35 | Launching a JVM…

FATAL | wrapper | 2004/09/30 11:37:35 | Unable to execute Java command. The system cannot find the file specified. (0x2)

FATAL | wrapper | 2004/09/30 11:37:35 | “java” -Xms32m -Xmx256m -Djava.library.path="." -classpath “wrapper.jar;messengerd.jar” -Dwrapper.key=“uCZA7Ak7R8FhE2jt” -Dwrapper.port=32000 -Dwrapper.use_system_time=“TRUE” -Dwrapper.version=“3.1.1” -Dwrapper.native_library=“wrapper” -Dwrapper.service=“TRUE” -Dwrapper.cpu.timeout=“10” -Dwrapper.jvmid=1 org.tanukisoftware.wrapper.WrapperSimpleApp com.jivesoftware.xmpp.starter.XMPPServerStarter

FATAL | wrapper | 2004/09/30 11:37:35 | Critical error: wait for JVM process failed

ERROR | wrapper | 2004/09/30 11:37:37 | The Jive Live Assistant service was launched, but failed to start.

Also, when trying to run: messengerd.bat -t …\config\wrapper.conf, I get an error message stating that the service cant connect to the wrapper. Have you guys run into this before? FYI it’'s on a windows 2003 server box with the most current jdk as of today (1.4.2 I think).

Ryan

Hi Ryan,

You probably need to add the JAVA_HOME\bin directory to your path at the system level, rather than at the user level.

Regards,

Greg

You were right about setting the environment variables (PATH and JAVA_HOME) at the user level instead of the system level, so I corrected that, but I am still experiencing the error. Running the command from the error message in wrapper.log produces this error:

C:…\bin>“java” -Xms32m -Xmx256m -Djava.library.pat

h="." -classpath “wrapper.jar;messengerd.jar” -Dwrapper.key="_kKtjjpuBoXWPA_q" -

Dwrapper.port=32000 -Dwrapper.use_system_time=“TRUE” -Dwrapper.version=“3.1.1” -

Dwrapper.native_library=“wrapper” -Dwrapper.service=“TRUE” -Dwrapper.cpu.timeout

=“10” -Dwrapper.jvmid=1 org.tanukisoftware.wrapper.WrapperSimpleApp com.jivesoft

ware.xmpp.starter.XMPPServerStarter

Wrapper (Version 3.1.1) http://wrapper.tanukisoftware.org

Failed to connect to the Wrapper.

java.net.ConnectException: Connection refused: connect

Exiting JVM…

It seems like this is still cause by a setting somewhere, but I havent tracked it down yet.

Hi Ryan,

Havn’'t seen that before, but my first guess would be a firewall.

Regards,

Greg

I am running a firewall, and I’‘ve been researching that too: I have my xmpp ports open (5222, 5269 and 5223 for SSL) and I tried opening 32000 also, but no go. Also, my log doesn’‘t show any dropped packets coming from the server. I’‘ll let you guys know if I find anything - the server works perfectly otherwise and I think it is exactly what I’'ve been looking for,

Ryan

Ok, got it running now. The problem was with the configuration file for the wrapper. I’'m still not quite sure exactly what I did to make it work, but the last change I made was to change all of the paths in the wrapper.conf file from relative to explicit file paths.

Ryan