powered by Jive Software

Installing Messenger in Tomcat 5.5.9 as WAR File

Hi there,

currently i try to install JiveMessenger as WAR File into a Tomcat 5.5.9

I create the WAR file with the ANT-Task. Before this i run ANT-ALL

The WAR File is created sucessfully but there is no /conf /plugins /logs Folder integrated after deployment.

Then when i run setup i get the messengerHome Not Found Error like some other users here in the forum. After i read all theese posts i created a folder classes in the WEB-INF Folder. There i integrated the messenger-init.xml and set the path to messengerHome here.

After this i tried starting Tomcat with -DmessengerHome=PathToMyMessengerHome

But nothing helped.

So how i have to configure messengerHome?

My Tomcat is placed here here:

/home/myHome/Tools/tomcat/jakarta-tomcat-5.5.9

and i set messengerHome then to

/home/myHome/Tools/tomcat/jakarta-tomcat-5.5.9/webapps/messenger

But nothing worked …

Can anyone describe me exactly how to configure this? Or is my WAR FIle corrupt? Can anyone provide me a WAR File which is working fine? ( to: info at arrasz dot de )

Kind Regards

Achim

Hello

Using the “ant war” task, a target/war/messengerHome is created. Use this path as -DmessengerHome attribute (or move the directory somewhere, like $HOME/messengerhome/ and set the -D attribute to this directory).

Regards.

Hi,

i tried this all but it works not. I set read/write Permissions for ALL!!! to the messengerHome Folder. This also didn’'t work.

I read that the messenger-init.xml file which must be located in /WEB-INF/classes could also be named as jive-init.xml? Where is the difference?

Any help is appreciated

Kind Regards

Achim

Hey Achim,

I just created a new document in the knowledge base about how to install war files. Take a look at the url=http://www.jivesoftware.org/community/entry.jspa?externalID=431&categoryID=2 2KB doc[/url] and let me know how it goes. Hope that helps.

Regards,

– Gato

Hi,

i tried installing the WAR File with hte Manager-App. At Tomcat startup there is nothing bad in catalina.out but when i reload the app with manager-app then i got the following exception:

2005.09.26 12:22:59 Reloading this Context has started

Could not locate home

java.io.FileNotFoundException

at org.jivesoftware.messenger.XMPPServer.locateMessenger(XMPPServer.java:610)

at org.jivesoftware.messenger.XMPPServer.initialize(XMPPServer.java:207)

at org.jivesoftware.messenger.XMPPServer.start(XMPPServer.java:266)

at org.jivesoftware.messenger.XMPPServer.(XMPPServer.java:133)

at org.jivesoftware.messenger.XMPPBootServlet.init(XMPPBootServlet.java:30)

at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1091)

at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:925)

at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:385 7)

at org.apache.catalina.core.StandardContext.start(StandardContext.java:4118)

at org.apache.catalina.core.StandardContext.reload(StandardContext.java:2930)

at org.apache.catalina.manager.ManagerServlet.reload(ManagerServlet.java:906)

at org.apache.catalina.manager.HTMLManagerServlet.reload(HTMLManagerServlet.java:4 56)

at org.apache.catalina.manager.HTMLManagerServlet.doGet(HTMLManagerServlet.java:98 )

at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFil terChain.java:252)

at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain .java:173)

at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java: 213)

at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java: 178)

at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.ja va:482)

at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)

at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)

at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:10 7)

at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)

at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)

at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnecti on(Http11Protocol.java:744)

at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:5 27)

at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorke rThread.java:80)

at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:6 84)

at java.lang.Thread.run(Thread.java:595)

Critical Error! The home directory has not been configured,

which will prevent the application from working correctly.

So i suppose that there is some kind of incompatibility with Tomcat?

I tried the following for now:

1.) start tomcat with startup.sh -DmessengerHome=/home/myHome/Tools/tomcat/jakarta-tomcat-5.5.9/webapps/messenge r/messengerHome

messengerHome has 777 rights and there is a folder /conf included where jive-messenger.xml resides. But i got this as second part of the exception:

ERROR 11277 ():

java.io.FileNotFoundException: XML properties file does not exist: jive-messenger.xml

at org.jivesoftware.util.XMLProperties.

Message was edited by:

Madness