powered by Jive Software

Installing Openfire on MacOS X.5.2

I just the other night downloaed and installed the MacOS installer package, I then ran it, then went to the OF prefpane in System preferences, where it allowed me to set a password, among other things. It then took me to the web interface where it proceeded to ask for my username and password which I provided. It then gave me an invalid username or password error. So far I’ve not found any docs that address this. Is this a simple of case of “You did this, you need to do this to fix it”, or should this not be happening and is only happening to me.

Thanks to all.

Matt

Not to state the obvious but the username and password you entered is case sensitive for both. Also what database are you using?

I understand about stating the obvious, I’ve done enough tech support over the years to know that it never hurts to ask… yes, I’m using “admin” and the password is 4 numerals. I’m using the internal database (I forget the name), though in time I might dable with MySQL. (It’s been a few years since I did any db playing around…definitely NOT an expert.

I installed it today on another machine running,this one running 10.4.11 (other one 10.5.2) and used a text string for the password, and was able to get in fine. Even configured a server and had a jabber client connect to it. Pretty simple really. So, either I mistyped the password when I set it on this machine, twice (which isn’t impossible…) or something else is wrong. How would I go about “resetting” the admin password, given I’m using the built-in database?

I’ll probably end up putting this on a linux box anyway, but I have lots of opportunity to mess with it on a Mac box since I primarily work on one all day. That’s why I was setting it up on a Mac.

Can anyone tell me how to reset the admin password? I know I entered correctly, but it doesn’t work…So I want to try to reset it.

You can reset it by changing the tag to false and rerunning setup. (it should remember all of your settings to it should primarily be an exercise in clicking next =) )

I do have the same problem and would like to reset the password.

did not get it how to change tag to false, where to find and how to do?

Hi Matt –

It’s possible you’re being bitten by the permissions issue I noted here:

3.5.0 install on Mac OS X, permissions are wonky

Check that the /usr/local/openfire directory has r/w permissions for the ‘admin’ group, might help.

–Mike

I found the setting in openfire.xml file located on my 2003 server at “C:\Program Files\Openfire\conf\openfire.xml” I open the file in notepad and set true tag to false, saved the file and restarted openfire. The wizard popped up again and all my setting was saved still.

To conform to other progs installed under /usr/local, you should change the group ownership to “wheel”, as follows (after finishing the setup, but before attempting to log in):

  1. In Sys Prefs: Stop OpenFire
  2. In Terminal: sudo su -
  3. cd /usr/local
  4. chgrp -R wheel openfire
  5. In Sys Prefs: Start OpenFire

You should now be able to login as admin.

I had this problem too, and I think the short answer is that the setup script doesn’t save the password, and then the default password “admin” is too short (five characters) to be accepted.

http://iharder.freepgs.com/2009/07/28/openfire-installation-note/

-Rob

Rob,

Known bug with openfire that is fixed in the next release. did you restart openfire once after setup?

daryl

Lotsa times. Lotsa fiddling. Manual password change worked OK. Good to hear it’s fixed. I seem to recall having this problem some months ago when I was experimenting with Openfire. I seem to recall canning OF back then too, but I was only exploring – I don’t need an XMPP server for anything.

-Rob