powered by Jive Software

Installing OpenFire on OpenSuse 10.3

Help Needed.

I am installingOopenFire 3.6.3 on Opensuse 10.3 using postgre SQL.

Evering seem to be connected, wen I call localhost:9090 the 1st time I am able to fill all the needed information and continue to system admin where I created a few users (I can see the entries of the new users in the postgre database). However, everytime after that when I call localhost:9090, I only get the initial registration screen.

Can somebody assist me and tell me what is wrong ?

Thank you

Hi,

use “ps -ef|grep java” to identify which user is running Openfire. Then locate the Openfire home directory and make sure that the user can write conf/openfire.xml.

I assume that root owns conf/openfire.xml while Openfire does not run as root.

LG

Thanks and this is the result :

This is the initial result :

hady@citra001:~> ps -ef | grep java
daemon 3596 1 0 10:57 ? 00:00:06 /opt/openfire/jre/bin/java -serv er -DopenfireHome=/opt/openfire -Dopenfire.lib.dir=/opt/openfire/lib -classpath /opt/openfire/lib/startup.jar -jar /opt/openfire/lib/startup.jar
hady 5298 5288 0 11:11 pts/3 00:00:00 grep java

This is the result after I run /opt/openfire/bin/openfire.sh

hady@citra001:~> ps -ef | grep java
daemon 3596 1 0 10:57 ? 00:00:06 /opt/openfire/jre/bin/java -server -DopenfireHome=/opt/openfire -Dopenfire.lib.dir=/opt/openfire/lib -classpath /opt/openfire/lib/startup.jar -jar /opt/openfire/lib/startup.jar
hady 6383 4420 44 11:13 ? 00:00:03 /opt/openfire/jre/bin/java -server -DopenfireHome=/opt/openfire -Dopenfire.lib.dir=/opt/openfire/lib -classpath /opt/openfire/lib/startup.jar -jar /opt/openfire/lib/startup.jar
hady 6403 5288 0 11:13 pts/3 00:00:00 grep java
hady@citra001:~>

And when I call localhost:9090, I got the setup screen and when finish it doesn’t want to continue to the admin page.

I even tried using root password, with the same result.

Any idea whay i should do next ?

Thanks.

Hady

Hi Hady,

you may want to kill 6383 as user hady or root and then always use user root and the /etc/rc.d/init.d/openfired script to start or stop Openfire.

What does ls -l /opt/openfire/conf/openfire.xml returns? The file should be writeable for daemon.

LG