powered by Jive Software

Installing Spark IM Client in Ubuntu Linux

Greetings,

I am attempting to install the Spark IM client under Ubuntu Linux. Here’‘s the stuff I’'ve done:

  1. Searched Synaptic package manager for Spark.

  2. Downloaded and untarred spark_2_5_1.tar.gz. It now resides in /home/johnny/Spark

  3. Tried to run Spark and starter in the base directory.

  4. Installed sun-java6-jre from Synaptic package manager. (Suspecting that Spark and starter would be recognized if I did).

  5. Checked the documentation folder for install instructions.

You know how they are always marking very obvious things like “don’'t take all the pills at once” on labels? Well, I’‘m sad to say that this time I’'m the guy who needs the spoon feeding. Can some kind soul please let me know where I should venture next in my quest to try out Spark IM?

Thanks,

Johnny

Hi,

If the error is after the login, then you should run with JDK 5 or with JDK6 and a new jdic, check http://www.igniterealtime.org/forum/message.jspa?messageID=145636#145636 for the last option.

Let me know if it is ok.

Regards,

Francisco

Greetings,

I’‘m not receiving an error, I’'m looking at the untarred files in my directory and wondering how to run the Spark client.

In windows I would double click the exe file, what is the linux equivalent?

Thank You!

Johnny

Hi,

You have to execute /home/johnny/Spark/Spark

If it does not work try:

  1. Open a Terminal

  2. cd /home/johnny/Spark

  3. ./Spark

Let me know if it worked or the error displayed in the terminal.

Regards,

Francisco

Greetings,

Thank you very much for your help. I’'ve made progress but no solution yet.

johnny@toucan:~$ cd /home/johnny/Spark

johnny@toucan:~/Spark$ ./Spark

No suitable Java Virtual Machine could be found on your system.

The version of the JVM must be at least 1.5 and at most 1.6.

Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.

You can also try to delete the JVM cache file /home/johnny/.install4j

johnny@toucan:~/Spark$

Johnny

Hi Johnny,

I guess you are running jdk 1.4. Could you verify it? Open a Terminal and execute java -version

If it is the case you will need to update it to jdk 1.5 at least. Be sure you add the new JDK version to the path.

Let me know if it is ok.

Francisco

This is how I resolved this error.

Check your java version in /usr/lib/jvm/ (depending on which versions you have installed you will see several.)

in the terminal do the following:

export INSTALL4J_JAVA_HOME=/usr/lib/jvm/java-*-sun (where * is your java version number.)

for example, on my 7.04 feisty system I ran

export INSTALL4J_JAVE_HOME=/usr/lib/jvm/java-1.5.0-sun

./Spark

If that works, go navigate to your Spark directory

cd /home/bluephoria/Desktop/Spark

nano Spark

Uncomment the following line

INSTALL4J_JAVA_HOME_OVERRIDE=

and change it to:

INSTALL4J_JAVA_HOME_OVERRIDE=/usr/lib/jvm/java-*-sun (again where * is your version number)

save the file.

and go!

Message was edited by: GTNman

That worked first time - thanks!

Greetings,

I am still having trouble. I have Synaptic Package Manager tweaked to explore universes, multiverses and all that other stuff, however, when I search for “jdk” I do not see the package I need to grab. What should I search for in order to upgrade my v1.4 jdk to v1.5?

Thank You,

Johnny

first which, version of ubuntu are you running.

you should be able to just run

sudo apt-get update

sudo apt-get upgrade

if that doesnt work, you can manually install it by doing the following,

sudo apt-get install sun-java5-jdk

however it may work with jdk 1.4 so just modify the line to reflect that.

Greetings,

It appears I have the correct version. I must be doing something wrong…

johnny@toucan:~$ sudo apt-get install sun-java5-jdk

Password:

Reading package lists… Done

Building dependency tree

Reading state information… Done

sun-java5-jdk is already the newest version.

The following packages were automatically installed and are no longer required:

libtext-unaccent-perl libcddb-get-perl libconfig-general-perl

Use ‘‘apt-get autoremove’’ to remove them.

0 upgraded, 0 newly installed, 0 to remove and 144 not upgraded.

johnny@toucan:~$

Johnny

Thank you all for your help. I’'m running spark on Ubuntu Linux!