Intallation on existing Red5 server

Dear All …

I Have Red5 installed on my box.

Is there any documentation on how to deploy RedFire on existing installed Red5 server ?

Can I just put the red5.war under existing Red5 webapp directory ?

Update : I tried to just install openfire in my red5 server, and it runs. But when I tried to also install the redfire plugin and restrat openfire … it stop working. When I stop my existing red5 application … the openfire and redfire works great. I’m prety sure it caused by port usage conflict. They are use the same RTMP port at 1935



Red5 + Openfire = Redfire. The plugin already has the complete Red5 server embedded.

Dear Dele.

Yup, I knew it.

So, is it mean that there is no way to set open fire to use “external” red5 server ?

Is there any docs on how to set redfire to use another port for RTMP ?



It is still a Red5 server. Look in the usual place


Dear Dele

Thankyou for your enlightment

I change the port to 2935

                <bean class="">
                    <constructor-arg index="0" type="java.lang.String" value="" />                      <constructor-arg index="1" type="int" value="2935" />                  </bean>

Now openfire looks running well …

the links at the test page will fail , sin the launcher page still refering to 1935

I can login to it via spark

I also download red5-plugin.jar to the spark plugin directory

Problem : I tried with two client station using spark.

The red5 button did not showed , bot in chat windows and conference window.

here is my at the client station

#Red5 Settings

Kindly please give me further enlightment

Software version :

  • openfire --> Openfire 3.7.0

  • redfire plugin -->

  • Spark -> 2.6.0



Use the latest version of the Redfire plugin for Spark 0.0.9 from

Post the warn.log and error.log file of your Spark client here for me to have a look.

Dear Dele

below is from my spark error log

Jun 21, 2011 3:51:02 PM addCaptureDevices
WARNING: com.lti.civil.CaptureException: java.lang.UnsatisfiedLinkError: no civil in java.library.path
com.lti.civil.CaptureException: java.lang.UnsatisfiedLinkError: no civil in java.library.path
    at com.lti.civil.impl.jni.NativeCaptureSystemFactory.createCaptureSystem(
    at org.jivesoftware.spark.preference.PreferenceManager.<init>(
    at org.jivesoftware.spark.SparkManager.getPreferenceManager(
    at org.jivesoftware.spark.filetransfer.SparkTransferManager.<init>(
    at org.jivesoftware.spark.filetransfer.SparkTransferManager.getInstance(
    at org.jivesoftware.spark.Workspace.buildLayout(
    at org.jivesoftware.LoginDialog$
    at java.awt.event.InvocationEvent.dispatch(Unknown Source)
    at java.awt.EventQueue.dispatchEvent(Unknown Source)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at Source)
Caused by: java.lang.UnsatisfiedLinkError: no civil in java.library.path
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.loadLibrary0(Unknown Source)
    at java.lang.System.loadLibrary(Unknown Source)
    at com.lti.civil.impl.jni.NativeCaptureSystemFactory.createCaptureSystem(
    ... 19 more



Message was edited by: Bino Oetomo says that the flash player is 10,3,181,14 OS = Ubuntu Maverick

com.lti.civil.CaptureException: java.lang.UnsatisfiedLinkError: no civil in java.library.path

That does not look good. What OS are running on the clients and what is the Java version??

How about the warn.log please ?

Dear Dele …

I’m pretty sure this caused by my stupidity …

I try to remove my ~/.Spark

The Icons showed up !!

Now I’ll try to use it and I’ll report the result

My firststation is UBUNTU Maverick

The second one is XP …

In ubuntu … I think spark make a copy of the plugins to ~/.Spark first if this directory not exist …

and run the plugin from that directory … not from “original” plugin directory.

If this is the case … I think spark better to just make a symlink … not a hardcopy

btw … where is spark make this directory in XP ?



X:\Documents and Settings[[USERNAME]]\Application Data\Spark