powered by Jive Software

Internal server name is provided for files download: how to change to external domain?

Hello community,

I’m running Openfire 4.2.1 on Windows Server 2012. This server is internal reachable as “shadowserver.int” and external as “mydomaincom”. For XMPP-client I’m using on Android “Conversations” 1.23.4 and all seems to work fine except for sending pictures (files in general), on Desktop I’m using Spark 2.8.3.

In “Conversations” (connected from outside) the sent files cannot be retrieved, the client is trying to fetch it via “shadowserver.int” instead of “mydomain.com

I have searched high and low but seem not able to find how I can have Openfire provide the “mydomain…com” to the clients.

I hope some can push my in the right direction.

Thank you

ShadowHunter

You’re likely using the HTTP File Upload plugin for this.

This plugin implements functionality that sends intended recipients a URL from where the data-to-be-transferred can be downloaded. As part of this URL, it uses the fully qualified domain name of the server that is hosting Openfire. Openfire typically automatically detects this value, but it can be overridden by setting the xmpp.fqdn property. Beware: Setting that property likely requires a restart of Openfire, and might affect the clients that are connecting from inside your private network. Ideally, you set this to a value that is recognized by all your clients.

Hello Guus,

Thank you for your reply and for your great plugin. I’m indeed using it.

The “xmpp.fqdn” property was already set to “mydomain.com

“shadowserver.int” is defined in my Sophos UTM as a static route which resolves to the internal sever IP… This is the only place where it can originate from (it was also in the Windows host file) I have now removed both the static route and the entry in the host file…

I’m gonna restart the Openfire tonight. I’ll keep you informed on the outcome.

Again thank you for your feedback.

With best regards,

ShadowHunter

Update:

Could not wait to restart tonight… just did it quickly :slight_smile:

It finally works:

This was the solution:

  1. Removed the static entry in host and in Sophos
  2. Forgot to forward port 7443

Thank you for pointing me in the right direction.

With best regards,

ShadowHunter

1 Like