Invalid Username or Password: External Network

Our district’s Openfire 3.6.3 (Win Server 2003) server has been up and running smoothly for a few months internally. However, I have not been able to successfully connect to it from outside the network. I have adjusted tons of firewall setting and that does not appear to be the issue, I can telnet into the URL with the open port. I have tried changing the port number and tried several different types of logins (i.e. username,, Every variation of what I have tried leads to the same error: Invalid username or Password. It appears that the Spark client is contacting the server but not authenticating?

I had Openfire 3.6.3 on an old webserver and was able to connect to it from outside of the network. Any suggestions on what may be the issue?

Thanks, Brandon

are the server names internally and externally the same? ie: are you calling the same server name internally as externally for the xmpp.domain setting under system properties.

I’ve even had capitalization stop the connection. ie: xmpp.domain = user configured the client with

You should only use username type of login. Server part should go into server field. You can try pressing the Advanced button on Spark’s login screen and put your server’s IP address into host field. And then use your server’s name in the server filed on the login screen.

I dont know how Spark’s login is functioning, but i’m starting to think, that even if Spark can reach the server and username and password provided are correct, it cannot succeed then some username-domain scheme is not followed. Like if you try to put your IP address into server’s filed, but Spark sees that server has a domain name and then it refuses to connect, or maybe it’s Openfire refusing it. Or maybe this is some sort of DNS issues and are not related to firewalls. Hard to tell. Such login problems are always a mystery and probably only a Spark’s original developer or some network savvy pro can answer that. But we have not any of them here…

Yes, I have used the exact same internal and external server name. I double checked and they are all lowercase. Thanks!

I have tried just using the external IP instead of the URL and I tried putting the IP in the host field and the URL in the server on the login screen, still no anvil. I will base my further attempts on just using the username type of login. It does seem like it may be some type of DNS issue. Is there anywhere in the Openfire Admin configurations that I should specifically be looking? Thanks!

I have this issue a few days, here the problem bem solved put ip server in the exclusion list in Sonicwall Firewall.

If you have a firewall on you network try this.


Hi Suhanov

i know you posted this long time ago, i have sonicwall firewall , my openfire server address is

I guess , I should put this to exclusion list . how? and why