powered by Jive Software

Invalid username or password

I’‘ve seen a lot of different cases as to why this error messages comes up but no resolutions that will fix mine. I’'ve never been able to login to Spark. I can create a new user account from Spark -> Openfire, but those accounts do the same thing.

Here’'s the error log on the OpenFire side from when i try to login from Spark:

org.jivesoftware.openfire.nio.ConnectionHandler.exceptionCaught(ConnectionHandle r.java:109)

java.lang.IncompatibleClassChangeError: Found class org.jivesoftware.openfire.session.Session, but interface was expected

at org.jivesoftware.phone.xmpp.PresenceLayerer.sessionCreated(PresenceLayerer.java :229)

at org.jivesoftware.openfire.event.SessionEventDispatcher.dispatchEvent(SessionEve ntDispatcher.java:62)

at org.jivesoftware.openfire.SessionManager.addSession(SessionManager.java:747)

at org.jivesoftware.openfire.session.ClientSession.setAuthToken(ClientSession.java :487)

at org.jivesoftware.openfire.handler.IQBindHandler.handleIQ(IQBindHandler.java:127 )

at org.jivesoftware.openfire.handler.IQHandler.process(IQHandler.java:48)

at org.jivesoftware.openfire.IQRouter.handle(IQRouter.java:300)

at org.jivesoftware.openfire.IQRouter.route(IQRouter.java:104)

at org.jivesoftware.openfire.spi.PacketRouterImpl.route(PacketRouterImpl.java:67)

at org.jivesoftware.openfire.net.StanzaHandler.processIQ(StanzaHandler.java:289)

at org.jivesoftware.openfire.net.ClientStanzaHandler.processIQ(ClientStanzaHandler .java:79)

at org.jivesoftware.openfire.net.StanzaHandler.process(StanzaHandler.java:254)

at org.jivesoftware.openfire.net.StanzaHandler.process(StanzaHandler.java:153)

at org.jivesoftware.openfire.nio.ConnectionHandler.messageReceived(ConnectionHandl er.java:132)

at org.apache.mina.common.support.AbstractIoFilterChain$TailFilter.messageReceived (AbstractIoFilterChain.java:703)

at org.apache.mina.common.support.AbstractIoFilterChain.callNextMessageReceived(Ab stractIoFilterChain.java:362)

at org.apache.mina.common.support.AbstractIoFilterChain.access$1100(AbstractIoFilt erChain.java:54)

at org.apache.mina.common.support.AbstractIoFilterChain$EntryImpl$1.messageReceive d(AbstractIoFilterChain.java:800)

at org.apache.mina.filter.codec.support.SimpleProtocolDecoderOutput.flush(SimplePr otocolDecoderOutput.java:62)

at org.apache.mina.filter.codec.ProtocolCodecFilter.messageReceived(ProtocolCodecF ilter.java:200)

at org.apache.mina.common.support.AbstractIoFilterChain.callNextMessageReceived(Ab stractIoFilterChain.java:362)

at org.apache.mina.common.support.AbstractIoFilterChain.access$1100(AbstractIoFilt erChain.java:54)

at org.apache.mina.common.support.AbstractIoFilterChain$EntryImpl$1.messageReceive d(AbstractIoFilterChain.java:800)

at org.apache.mina.filter.executor.ExecutorFilter.processEvent(ExecutorFilter.java :266)

at org.apache.mina.filter.executor.ExecutorFilter$ProcessEventsRunnable.run(Execut orFilter.java:326)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

And here’'s the error log from the Spark side:

No response from the server.:

at org.jivesoftware.smack.SASLAuthentication.bindResourceAndEstablishSession(SASLA uthentication.java:307)

at org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java: 214)

at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:341)

at org.jivesoftware.LoginDialog$LoginPanel.login(LoginDialog.java:785)

at org.jivesoftware.LoginDialog$LoginPanel.access$400(LoginDialog.java:185)

at org.jivesoftware.LoginDialog$LoginPanel$1.construct(LoginDialog.java:589)

at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:129)

at java.lang.Thread.run(Unknown Source)

Funny thing is that when I try that first time to login and get these errors, I go to the Client Sessions on OpenFire and it shows my session as Connected and Online!

If i try to login again after this, i get the ‘‘normal’’ lines in the Spark error log because of the pre-existing connected session (and yes, I have the Resource policy set to Always Kick):

stream:error (conflict)

at org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:306)

at org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:44)

at org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:76)

But it still doesn’'t log in, it gives the same ‘‘Invalid username or password’’

I have the Spark client set with the servername hardcoded in (instead of Automatically discover host and port).

Just found my answer.

Under the Resource field, i needed the correct Group Chat Service Name.

Maybe this will help someone else who is having a long day.

i have the same problem,

same logs and same message, so into my spark under resource i put "spark and also under “Group chat service name” but still i get “invalid username or password”

please help

thank you in advance

fabio

Help

I also have this Login-Problem here since I upgraded to the newest Openfire-Version (3.3.2).

Before I had an older OpenFire running, so I deinstalled it and did a new Install for OpenFire (as I found no suitable update-Information anywhere).

Now the only client to be able to log into Openfire is my Trillian Pro.

Spark and Psi give me the error mentioned by the first poster in this thread…

I really need a fix here

Anybody able to help?

Thanks a lot in advance for your help!

Best regards,

Christian

Update:

I have just for fun disabled the Asterisk-IM Plugin.

Now it works

So the Problem lies within Asterisk-IM-Plugin and the new Openfire-Server…

But why does a PlugIn block me from logging in? And why all clients but Trillian?

Questions over questions…

Best regards,

Christian

Hmm thats strange. Can you try another version of Asterisk-IM?

1.4.0-SNAPSHOT is available at http://maven.reucon.com/public-snapshot/org/jivesoftware/phone/asterisk-im/1.4.0 -SNAPSHOT/asterisk-im-1.4.0-20070624.210118-1.jar

Just rename it to asterisk-im.jar and put it into the plugin folder of Openfire.

Please report back if the problem persists or not.

Thanks,

Stefan

confirm,

I also tried to unload all the plugins from openfire 3.3.2 and i can log in with spark, now

if i load asterisk-im plugin 1.3.0 with or without enable it, i can’'t login with spark anymore

thank you

fabio balzano

italy

using the new snapshot 1.4.0 of asterisk-im the problem is resolved,

finally i can log in with my spark

thank you

fabio balzano

italy

Thnaks for testing.

This problem is now fixed in Asterisk-IM 1.3.1 which will shortly appear on the Plugins page.

For now you download it from http://www.reucon.com/~srt/asterisk-im/1.3.1/asterisk-im.jar and install it manually.

I am having the same error but I don’'t use asterisk-im.

Is there something else that could be causing this?

What’'s the easiest way to send some sort of backtrace from Spark on Windows (2.5.4)?

I had this very same problem with an interesting twist.

I installed Openfire 3.3.1 on an XP workstation (just to have a look at the interface etc). I installed Openfire 3.3.2 on a W2K3 server, and I installed Spark 2.5.3 on same workstation with the Openfire installation. I connected Spark to the W2K3 server just fine.

However, when I installed Spark on 2 other identical workstations, I kept getting the ‘‘invalid username or password’’ error.

The only difference between the 3 workstations is that the one that successfully connected had the installation of Openfire 3.3.1.

I read the forums, and tried removing all plugins from the Openfire 3.3.2 installation on the W2K3 server. No luck.

Finally, I just uninstalled version 3.3.2, and replaced it with 3.3.1 on the W2K3. All clients are now able to connect. However, so far I am unable to use the Gateway plugin!