Invisible user when chat room

dear all,

i got problem, i have created room and the name of this room was cmc. the problem was in group chat i could’t see any users online but they could chat in that room and they could see that i was already inside of room

Where did you create this room? In the Admin Console or in Spark? Can you show the setting of this room?

i created it in open fire ( admin console )

hi wroot, can you help me on those errors

Sorry, i can’t reproduce your problem, so i can’t help.

I’ve faced this issue today myself and was able to reproduce this on my test server. The problem is that Spark for some reasone doesn’t show users in chat room if you have disabled “Show chat roles icons instead of presence icons” in Preferences > Group chat and if you are simple visitor or a member. If you are admin or owner it will show both presence or chat role icons. So you have two workarounds until this is fixed: switch to show chat role icons (different stars for different roles, but you won’t see who is away or dnd this way) or add all members to admins.


wroot,it means i should tick every users show chat role icons instead of presence icons?

If one has Preferences > Group chat > “Show chat roles icons instead of presence icons” enabled, everything is fine. But if you have this disabled, it should show presence bubbles in the list instead of role icons.

only one person enable show chat role icons instead of presence icons

Yes, unfortunately, you have to change this setting for every user who is not an admin or owner of the room.

Another option for you is to turn Show Real JIDs of Occupants to: option to Anyone in your rooms. Then it will show presence bubbles also.

wroot : how can i display Real JIDs of Occupants to every user?

This is done in the room settings in admin console. Last setting.

you mean on my attachment files? default room setting.png ? tick 'can anyone discover real JIDs of Occupants

I mean when you create new room or edit existing. But you can check this setting on the default room settings page from your screenshot. Then all new rooms will have this setting enabled automatically.

This has been resolved in the latest nightly build (733) Ignite Realtime: Spark Nightly Builds And the fix will also be included in the upcoming 2.7.4 release this week.