Ipod/Iphone with Openfire

Hi friends, I have a Openfire server 3.6.3 with spark’s clients. But I have problems to connect my iphone with IM+(and all jabbers clients for iphone/ipod) to my server… it doesn’t work… … somebody help me.

I have the same problem. I have contacted Shapes Services who is the software developers for IM+ for iPhone and they said they are working on it. This was about 6 weeks ago and there has been 2 updates since then. It is is still not working and wish it work.

I would love to see sparks with fastpath/webchat on the iphone. Love it on my desktop but sometimes I am mobile.

According to Shape Software when I contacted them last week:

Unfortunately IM+ won’t be able to reach the jabber server not accessible from outside.

So it doesn’t sound likely.

Sucks as I would love a way to chat on the go and IM+ is available for all the mobile platforms my co-workers have.

I’ve keep emailing them for ETA and they said they are still working on it. So, I have checked in iTunes and see there is one that works with openfire which is called OneTeam, http://www.process-one.net. I haven’t tried it.

Have you tried this one or another one that works on iPod/iPhone with openfire?

My fear is I will spend the $$$ and not get what I need. Will it work on a network that does not get out side (i.e. a intranet)? Anyone use it like this. I got a response from IM+ who said that this is not possible with the current version.

got a response from Shape Services, good news for openfire users and using IM+.

=== start


Thank you for your patience.

The Jabber server you are connecting to requires STARTTLS support,
and this feature is not available in the current version of IM+. it will be
added to the next versions of the application. Please keep an eye on
the updates.

Please feel free to contact us if you need any further assistance.

Best regards,
Aleksander Ostrovsky
SHAPE Support Team
SHAPE Services

Have you tried Monal? I have been using it for a couple of weeks… Looks fairly good.

And its free

Any help or insight in how to setup Monal? It seems promising, but I have not had anyluck getting it to work.

Dennis -

We embed openfire into our UC product but it is essentially the same.

In my config, OpenFire is running on default port (5222) and SSL is turned off on the server for client connection.

So here is a quick run down on Monal Config:

  • In Monal, Go to “Account” then select XMPP under Add New Account.

  • Fill out the config details

  • Jabber ID: This is your full Jabber ID / Roster name. Its usually something like yourid.@server format.

  • Password: your password

  • Enabled = ON

Under Advanced Setting:

  • Server: Host name or IP address of your Openfire server.

  • Port: 5222 (ulness you have changed it on the server)

  • Resource: monal (does not really matter what you call it… )

  • User SSL: Depend on your setting on the server. If you have SSL enabled, turn it on else turn it off.

Thats it … its fairly easy.

If you can not connect, I owuld start with a Windows/linux/Mac client on the same network to see if that works…could be a network / connection issue.


I’m the developer of Monal. Openfire is one of the servers that I test regularly with and this should work fine with every version of openfire going back to when it was called wildfire. The instructions posted on this page should work. Let us know if it does not work.

monalxmpp, I know this is connecting because it tells me that my server is not supporting SSL. Once I turned that off, it told me that it couldn’t. Now, I believe it is because it insists in putting an @ sign after my id.

Say my id is thomas, it uses thomas@ no matter what I do. We normally use a Sparks client and the client does not use a domain name in the id. Is there a way to remove that. I think that is the stopper right now.

Thank you

I have an openfire to test with so i will replicate your setup and see what the problem is.

unless im am mistaken the standard way of doing jabber is username@domain.com and usually domain.com is server.com.

Have you ever used pidgin? how do you set up that connection?

Hi Monal,
The openfire server is a corporate server, so I am not sure if it is configured to assume a domain by default because we have multiple domains. I tried with my Sparks client (instead of using joe like I normally do, I used joe@companydomain.com (company domain being the real sam account domain info) and it did’t work. I have to use just joe which is my id.

*UserID: I am using my id, joe, which it converst to joe@

  • Password: your password
  • Enabled = ON
    Under Advanced Setting:
  • Server: fully qualified name of openfire server just like it showns in Sparks
  • Port: 5222 (which is what the Sparks client also uses)
  • Resource: monal
  • User SSL: Off - because it gave me a message saying that SSL was not enabled on my openfire server

I have not used pidgin. I will try to find it and try it . I assume there is no iPad version for it, but I assume you are suggesting I try it on my windows machine just to compare.

Thank you

I have made a change to the login method in the next release (out in the next couple of weeks) so that it doesnt put that @ at the end of names where there is no domain. I think that should fix your problem. I will post again when the next version 2.0.4 is available.

Hi, 2.0.4 is out. Let me know if you still can’t connect.

It works fantastic! Hats off to you, thanks