Is It Possible That 1 Wildfire Server With 2 Networks?

I have a wildfire serever in a DL 380 with 2 NICs. Now the server’'s IP is, but now I want to connect another network with the other NIC whose IP is

Is it possible?

Or if it is, how to configurate the server?

Thanks very much.


Hey broom,

If you don’'t specify network.interface in wildfire.xml, you need not do anything because Wildfire will bind and listen to all available network interfaces in your server including the loopback ( If you specify network.interface then you should explicitly define:

Refering to inbound connections, as long as your clients can resolve to any of your server’'s IP addresses at any of the interfaces, they should be able to connect to your server. E.g. clients from network would connect at, whereas, clients from will connect at In most cases, this should be transparent to you.

If you’‘re refering to outbound connection like server to server (S2S) connection whereby your server will connect to other external server (e.g., then first, your server should be able to resolve to an IP. After that, it depends on the routing table of your server. If resoves to e.g. the static route in your server’‘s routing table should route the connection to the interface that has as its IP. If there isn’'t any static route then your server will attempt connection on the interface which is defined as the default gateway.

OK, thank you very much.

I’'ll try at once.

First time, I didn’'t change wildfire.xml and connect the server with the other NIC. I filled “” in login server, but a Login Error occured: Invalid username or password. So I added an item in “hosts” File: But it still failed.

Second time, I changed wildfire.xml. I added

in it. Restarted wildfire and connected.

It failed either with different error: Can’'t connect to server: invalid name or server not reachable.


Thank you very much.


The changes that you should make is at the client’'s side. First, make sure that is also defined in Server->Server Settings->Server Name in the Administration Console of your Wildfire server.

Then, if you’‘re using Spark, the simplest way is that you enter at the Server: box of the login screen. Then click on Advanced button. On the Preference Window->General tab, unclick Automatically discover host and port, then enter’'s IP address in Host: box. Try to login.


what did you specify as xmpp.domain aka server name? This should be and you must use SRV records for xmpp so that the clients (and remote servers) connect to your Wildfire server.

Or you do the very easy setup and use normal DNS entires with a name like - but there the email address will not match the xmpp address.


Dear aznidin?

I have done what you said, but it failed still…

Any other suggestion?

Dear LG,

Actually, the domain name of server is But after I restarted yesterday, IP has change to in Administration Console.

I use a computer with IP to ping, there are replies.

But I still couldn’'t login. The same error occored: server unreachable.

What to do next?

Thank you very much.



please check with “netstat -an|grep 5222” which IP addresses Wildfire is using.


Message was edited by: it2000 “@” --> “|”

From the client pc that failed to connect, can you:


What is the result?

Dear LG,

It’'s NOT listening.

I have restarted wildfire service, should I restart HP Server?

Thank you very much.


Message was edited by: broom25


so where is it listening? “*.5222” or ???


LG? is listening and established.


the Wildfire-IP-bind problem. Comment the network section in conf/wildfire.xml so Wildfire binds to all addresses. It seems that it can accept just one specific IP address.

Or make sure that there is just one address and use a connection manager for the other IP address. The web admin interface will then not be available for the second IP address.


Dear LG,

I’'ll try this later today.

Thank you very much.


After 2 weeks, it’'s OK now.

But there is a little trouble: I want the second NIC( connect to Internet. For safety, I put a PIX firewall between. And clients get connect throught VPN.

First, a PC with an Internet IP connects the server successfully though it’'s slow.

Second, a PC with an Intranet IP which is given by a router failed to connect the server.

And when I ping the server IP, it says that:

Pinging with 32 bytes of data:

Reply from bytes=32 time=446ms TTL=128

Reply from bytes=32 time=449ms TTL=128

Reply from bytes=32 time=452ms TTL=128

Reply from bytes=32 time=518ms TTL=128

What’'s the matter?


did you set up a local DNS for your LAN?

Or does your intranet client connect to your public interface as your xmpp.address resolves to a public address?


Dear LG,

I didn’'t setup a DNS for either NIC.

And my intranet client DOES connect to the interface by which mapped to;

but my Internet client connect to the interface by IP directly with VPN.

Thank you very much.